Page MenuHome

eevee - lamps in a reflection plane are visible in a render, and even be visible through solid objects.
Closed, InvalidPublic

Description

System Information
Operating system: Windows 8.1
Graphics card: Geforce 860m

Blender Version
Broken: 2.8 - 2019-04-26

Short description of error
when using a reflection plane, lamps will show up in the reflection in a render, but not in the viewport. to make matters worse, the lamp can actually shine through the corner of an object (meaning it will be visible in the reflection even tho its behind the object.

Exact steps for others to reproduce the error
The attached .blend file has the most basic example setup I could come up with.
The bottom-left has the viewport, set it to rendered mode. Neither lamp is visible.
Hit the render button, the rendered view shows the lamp on the left, and the one behind the cube will be showing through as well.

Here's a comparison image:

and the blend file:

Details

Type
Bug

Event Timeline

This is also demonstrating a 'light leaking' behavior (the specular shine on that edge that shouldnt be there either) that has been reported as: https://developer.blender.org/T64787
Maybe its related?

In addition to T64787 mentioned above, is this also related to this thread: https://developer.blender.org/T57752 perhaps? This thread is about backlight / specular leaking into contact shadows....

Clément Foucault (fclem) closed this task as Invalid.
Clément Foucault (fclem) claimed this task.

Your light shadow map clip start is too big. The cube is clipped and not rendered into the shadowmap. We changed the default to be much more forgiving.

Ah, ok, that explains the lamp thats shining through the object, thanks.
But, what about the reflected one on the side that is visible in the render, but not in viewport?

Im not sure which is intended behavior actually... but if a lamp is not visible when looking directly at it either in the viewport or render, it probably shouldnt be visible in the reflection in render?

This is how it works in prety much all renderes. Lights objects have no physical presence but are visible through their interaction with surface materials.