Page MenuHome

GRLESS key dont work in spanish keyboards.
Closed, ArchivedPublic

Description

Operating system: Linux-4.15.0-48-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GT 630M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-04-28 21:50, hash: rB337cac760ba9

The "GRLESS" key does not recognize blender for assign functionalities, however in the text editor if it recognizes it. In a pc with linux and in an imac therefore in different keyboards both Spanish keyboards do not recognize this key for assign functionalities.

I've also tried this on my addon, but it doesn’t work. In the text editor recognize the key, so the key is correct. And it happens in the laptop with linux mint and at work it also happens with an imac.

kmi = km.keymap_items.new('wm.call_menu_pie', 'GRLESS', 'PRESS')
kmi.properties.name = "VIEW3D_MT_view_pie"
addon_keymaps.append((km, kmi))

Same code with the SPACE key it works well.

Relevant info: https://blender.stackexchange.com/questions/95685/what-is-where-is-grless-key

Details

Type
Bug

Event Timeline

zebus3d (ofuscado) updated the task description. (Show Details)

I can reproduce this bug with spanish keyboard on Linux.

Sebastian Parborg (zeddb) closed this task as Archived.
Sebastian Parborg (zeddb) claimed this task.

You can currently only assign keys that are in the ANSI US layout. In the ANSI US layout, the <> are not available without using modifiers (shift in this case). So the binding in blender would be shift + . for the > key for example.

This is a know issue. But we currently do not have any road map to when we are going to support other key types (as this would require a rewrite of our key handling system).

Because someone hacked that in way back. It will only work on certain keyboards (German, Italian) that have that key mapped to a very specific keycode.

The correct way to solve this would be to rewrite the input system so that we do not look at keycodes.