Page MenuHome

Eevee not updating shader properly when going into lookdev, unless object is transformed or edited
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.13.10-041310-generic-x86_64-with-debian-stretch-sid 64 Bits
Graphics card: GeForce GTX 1050/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.67

Blender Version
Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-04-29 17:52, hash: rB047081841113
Worked: rB337cac760ba9 (yesterday)

Short description of error
In the attached blend file, the object's shader is not updated/shown properly when going into lookdev mode, unless the object is transformed or edited.
It looks like it's related somehow to the parallax node tree, the material is using.
Worked fine until yesterday.

Exact steps for others to reproduce the error

  • open blend file
  • go into lookdev mode
  • notice how the objects material and its textures are not shown properly
  • move/rotate/scale/edit the obejct to update the shader

video demo

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Confirmed.

Also hitting an assert now:
BLI_assert failed: /blender/blenkernel/intern/data_transfer.c:284, data_transfer_dtdata_type_preprocess(), at 'CustomData_get_layer(&me_src->pdata, CD_NORMAL) != ((void *)0)'

@Clément Foucault (fclem): mind checking?

My issue seems to have been resolved in the lasted build bot rB480a09a92f7f

Clément Foucault (fclem) closed this task as Resolved.May 2 2019, 5:31 PM