Page MenuHome

Video Editing Sequencer Playback, Cache and Workflow Quirks
Closed, ArchivedPublic

Description

System Information
Operating system: 2018 MacBook Pro 13, Mojave 10.14.4
Graphics card: Intel Iris Plus Graphics 650 1536 M
(same on my big iMac)

Blender Version
version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-04-29 17:52, hash: 047081841113, type: Release
build date: 2019-04-30, 01:34:12
platform: Darwin

Short description of error
I tried Blender for using it as a storyboard/animatic tool and find some issues/quirks in case of playback, caching and workflow.

Exact steps for others to reproduce the error
Setup and issues:

  • creating different scenes with frame by frame animated grease pencil objects. (Scene.001; Scene.002; Scene.003)
  • create one extra scene to work within the video editing workspace (Animatic Scene)
  • add the scenes (001;002;003) to the video editing sequencer (Animatic Scene)
  • the experience scrubbing along the frames or moving the strips is very very bad until it caches
  • starting the playback without caching, the playhead is jumping over some frames so it doesn't fill the cache 100% while playing
  • i have to move the playhead manually frame by frame to get a 100% filled up cache - then the playback is fine (dedicated cache now/all button?)
  • if I change something to the grease pencil scenes nothing updates until I move the strips manually (dedicated cache again button?)
  • if i am working in the video editing workspace and I switch to a grease pencil scene it stays in the same video editing workspace and I have to change the workspace every time I switch from video editing to grease pencil scenes (a real pain making an animatic). it would be nice if the workspace is kind of connected to the scene.

Thanks,
Thomas

Details

Type
Bug

Event Timeline

@Thomas Kress (AnimationXYZ) You'd have to share a .blend file for us to see what exact issues and the extent of them are.

the experience scrubbing along the frames or moving the strips is very very bad until it caches

This is a known limitation, until prefetching comes

i have to move the playhead manually frame by frame to get a 100% filled up cache - then the playback is fine (dedicated cache now/all button?)

The sounds like a bug

if I change something to the grease pencil scenes nothing updates until I move the strips manually (dedicated cache again button?)

@Richard Antalik (ISS) Is cache invalidation aware of this?

starting the playback without caching, the playhead is jumping over some frames so it doesn't fill the cache 100% while playing
i have to move the playhead manually frame by frame to get a 100% filled up cache - then the playback is fine (dedicated cache now/all button?)

This is because you have AV-sync enabled.
https://docs.blender.org/manual/en/dev/editors/timeline.html#playback-pop-over

if I change something to the grease pencil scenes nothing updates until I move the strips manually (dedicated cache again button?)

It is not possible to tell what objects will affect scene strip(also in what range) used by sequencer. Refreshing this requires manual action. In sequencer there is refresh all button (upper right corner of timeline)
https://docs.blender.org/manual/en/dev/editors/vse/sequencer/navigating.html#refresh-sequencer

If you don't want to clear the whole cache, you can select strip, hit key g to move the strip and then press escape to cancel action. This will clear cache for single strip.

if i am working in the video editing workspace and I switch to a grease pencil scene it stays in the same video editing workspace and I have to change the workspace every time I switch from video editing to grease pencil scenes (a real pain making an animatic). it would be nice if the workspace is kind of connected to the scene.

I would agree, but I am not sure if current design allows this.
As a workaround I can suggest using multiple windows or perhaps some addon, that would make this process easier.
But certainly I am not the right person to discuss this point...

Sebastian Parborg (zeddb) triaged this task as Normal priority.May 2 2019, 11:29 AM

@Sebastian Parborg (zeddb) I really don't know how works the Video Sequencer and I think here we need someone in this area, so I cannot help too much here.

The main issue here is slow playback. While bug is solved, this may remain an issue depending on machine performance - therefore it is subjective.

As far as VSE cache goes invalidation and background rendering are being worked on. This also may or may not fully resolve performance issue. Depends on application.

What I am trying to say, that there is not much to solve / fix in this report yet. At least from my point of view(workspaces bound to scene issue).

Sebastian Parborg (zeddb) closed this task as Archived.May 2 2019, 2:08 PM
Sebastian Parborg (zeddb) claimed this task.

Ok, I guess we can archive this then.