Page MenuHome

Red Line on menu bar (Mac OS)
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Darwin-18.5.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 560 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.8.38

Blender Version
Broken: version: 2.80 (sub 60), branch: master, commit date: 2019-04-29 15:21, hash: rBfa5dd59f983e
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]

I have a bug when use hide menu bar on my mac, please check that.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.May 2 2019, 11:29 AM

@William Reynish (billreynish) can you reproduce this?

No, it seems to work normally here on MacOS Mojave 10.14.4. Could be related to a specific GPU or driver version?

No, it seems to work normally here on MacOS Mojave 10.14.4. Could be related to a specific GPU or driver version?

So... i have 4 different Mac's and have this problem on all. When i use full screen mode i see the red line, but if i turn off "Automatically hide and show the menu bar" it fix this bug and i can work without red line in full screen mode

No, it seems to work normally here on MacOS Mojave 10.14.4. Could be related to a specific GPU or driver version?

If you want to reproduce this bug you need to close blender, hide your menu bar and after open blender go to full screen mode. If you uncheck "hide menu bar" it fix blender red line and then you can switch back to the first setting and blender work correctly

@Alexander (Ba3ilik) I still cannot reproduce it here, even if I do it in the order you describe.

Brecht Van Lommel (brecht) lowered the priority of this task from Waiting for Developer to Reproduce to Needs Information from User.May 9 2019, 2:50 AM

We've had this reported before in T53123: Mac OS X - System Preferences > General > Automatically hide and show the menu bar. The conclusion there was that it happens in other apps too which makes it likely to be a bug in macOS itself that we can't fix in Blender.

Are you seeing similar issues in other apps when going fullscreen?

We've had this reported before in T53123: Mac OS X - System Preferences > General > Automatically hide and show the menu bar. The conclusion there was that it happens in other apps too which makes it likely to be a bug in macOS itself that we can't fix in Blender.
Are you seeing similar issues in other apps when going fullscreen?

So.. I use many applications and have this bug only with blender. But i have small bug in modo when i work with full screen, modo duplicate bottom menu line...look at this

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.May 25 2019, 1:26 PM

Hello, after the last update I see huge red square :)

@William Reynish (billreynish)

Turn on both the "Automatically hide and show the menu bar" and the "Automatically hide and show the Dock" and then run Blender.

Also, this bug only appears when you switch to fullscreen mode from a maximized window (like Blender runs by default),
but if you resize the window a bit, then everything works fine.

Sebastián Barschkis (sebbas) lowered the priority of this task from Waiting for Developer to Reproduce to Confirmed, Medium.Thu, Oct 10, 4:38 PM

Was able to reproduce this in ea1174bde9ed following @Yevgeny Makarov (jenkm) 's description. In fact, this bug even shows up in 2.79 (tried out both 2.79a and 2.79b).

It's likely that the OSX version plays a big role. I tested it on Mojave 10.14.6.