Page MenuHome

Principled BSDF base color value export problem.
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 960M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.39

Blender Version
Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-05-01 16:58, hash: rBa372e5e426e4
Worked: (optional)

Short description of error
Blender keeps the color value under the linked image texture nodes.

Exact steps for others to reproduce the error
Hello, if you have a color value (eg. blue) in the base color input before you link it to image texture node, and when you export it (does not matter what the exporter is) and then imported with another program like 3ds max there is like a blue-ish tint that visible on the object, it looks like blender keep that color value information under the linked nodes, and other programs, in this case, 3ds max perceive that value to diffuse color value.

now I don't know if this is a bug or a decision in the development, but shouldn't it be using its default value every time an image texture node links to the nodes that have base color value?

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

What format are you using for import/export?

What format are you using for import/export?

Fbx and obj

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.
Bastien Montagne (mont29) closed this task as Archived.May 7 2019, 3:34 PM

Thanks for the report, but that is not a bug, we cannot do much if other apps decide to use the color value to tint the texture input… In Blender color value is just completely replaced by the texture when one gets linked in. Issue can also come from the simplifications we have to do to translate the Principled BSDF-based shader into the old-fashioned fixed pipeline description that is the only available option to describe materials in most formats (FBX should support proper Principled-like shader, but that is to be investigated/known todo).

In general, modern shaders make it much, much harder to properly export a material (such that you get similar results in all importing apps). This can surely be improved, lots of tweaks and adjustments are possible, but this is a long-term TODO, as it would require access to lots of third party apps, and lots of time, to hope to get a decent result…

Hey, thanks for the reply, with this conversation I hope blender can have more compatibility when used side by side with another proprietary/supportive program. I wish you and the development team good luck.