Page MenuHome

No viewport anti-aliasing in the shaded mode in the latest 2.8 builds from blender-2.80.0-git.b331515d2e47-windows64 (May 03) onward
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 latest update
Graphics card: GTX 1070 Ti, GTX 1080 (another pc)

Blender Version
Broken: blender-2.80.0-git.ee0d8426ab6d-windows64 (May 04), blender-2.80.0-git.b331515d2e47-windows64 (May 02)
Worked: blender-2.80.0-git.a372e5e426e4-windows64 (May 01)

Short description of error
Viewport in the shaded mode looks considerably worse in the newest builds, lacks anti-aliasing.


Older build:

Exact steps for others to reproduce the error
The issue should be evident after opening the attached file.

What I tried

  • Deleted the Blender's settings folder
  • Set the Viewport settings to maximum quality
  • Tried on another PC
  • Shared the file on the Discord channel, another user confirmed:

Details

Differential Revisions
D4828: Workbench: Viewport AA Preferences
Type
Bug

Event Timeline

There has been a change in the design of the viewport quality and anti aliasing in general.

Every scene can set its anti aliasing method for the viewport and for rendering. This can be done when switching to the Workbench engine and then change the settings in the render sampling panel.

By default the viewport anti aliasing is set to Single pass anti-aliasing as the viewport should be as fast as possible. We cannot consistently determine the correct setting when loading older scenes (Viewport Quality is user setting, Viewport and Render samples are scene settings; this will lead to different result based on the user who loads the file), hence we set everything to the default values (Render: 8 samples, Viewport: Single Pass Anti-Aliasing) .

When you have a machine that is slower you want to have a setting to limit the viewport quality. This is the Viewport Quality setting in the user pref. This viewport quality setting only limits the Anti Aliasing samples if the setting in the scene is higher and only for drawing in the viewport. It will not change the anti aliasing method when saving the file.

During Viewport Render Image or Viewport Render Animation the Viewport Quality setting is not used.
When doing Render Image or Render Animation the Anti aliasing is used of the scene.

We have updated the manual to reflect these changes https://docs.blender.org/manual/en/dev/render/workbench/quality.html

Jeroen Bakker (jbakker) closed this task as Invalid.May 7 2019, 11:20 AM

Thanks for explaining this. It all makes sense now. An update to the View Qalityality setting tooltip, as well as Multisampling settings would help, however. By the way, the maximum Multisampling setting in the User preferences is 16 samples, and you can set up to 32 samples in the Scene settings, but how does it work together if the settings in the User preferences override the Scene settings when the Scene multisampling settings are higher?

Shouldnt this option be in the solid mode pop-up rather or in addition to it being in the workbench render settings?

Having to change the render engine to configure something related to the viewport seems a bit awkward to me...

Cheers.

Alphyn (Alphyn) added a comment.EditedMay 8 2019, 10:03 AM

Completely agree. That's the second place I checked when I realized the AA was gone (The first being the Viewport tab in the User preferences).

Yes, I agree this seems weird. We don't do it this way for any other viewport setting that applies to Solid mode - you don't have to switch to the Workbench engine to adjust.

When just using Solid or Wireframe view, we should set the AA quality with the Multisampling setting in Preferences

I guess I'll reopen this then.

Brecht Van Lommel (brecht) raised the priority of this task from Confirmed, Medium to Confirmed, High.

I think it's clearly a bug that the workbench render settings affect the viewport, this should be controlled by the preferences. The Viewport Quality setting in the preferences has no effect now as far as I can tell.

Ideally it would changed to a similar enum as the new ones for the workbench, since a 0..1 slider here is rather odd.

Setting the Viewport quality to lover values reduces the amount of anti-aliasing for me. Different Multisampling settings, on the other hand, don't seem to affect anything.

Will prepare the next changes:

  • Interactive viewport rendering will only use the user pref setting. The settings in the Sampling will only effect (Viewport Rendering/Animation and Render Image/Animation)
  • Viewport Quality will be replaced by a drop down list (Viewport Anti Aliasing)
Jeroen Bakker (jbakker) closed this task as Resolved.May 9 2019, 3:15 PM