Page MenuHome

Selection problem
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-4.15.0-45-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GT 1030/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-04-30 22:49, hash: rB480a09a92f7f
Worked: (optional)

Short description of error
When I try to select vertices or faces or edges from long distances or in tiny meshes the geometry behind them is also selected. But I don't want that, I want to select only the geometry I can see. The problem is pronounced more when I try to work with hexahedral meshes.

Exact steps for others to reproduce the error
Just try to boxselect from far distances, in the blend file I attached. You can see that you can select the geometry behind the geometry you can see.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.EditedJul 9 2019, 3:06 PM

I can't reproduce this by simply opening the file and trying to box select.
Is this still an issue with the latest build?

Yeah, That is still the issue. Check this file. I also didn't have an issue on the past length to the object, but now you can try it without moving camera before selecting.

Sebastian Parborg (zeddb) closed this task as Archived.Jul 9 2019, 5:35 PM
Sebastian Parborg (zeddb) claimed this task.

This is because of the precision in depth buffer:
https://www.youtube.com/watch?v=Sfy6pB0susM

When you have zoomed out that far, we can't select accurately. This is not something we can fix with out current implementation.