Page MenuHome

Missing contra key-code for isolute in outliner
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-15.6.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel Iris Pro OpenGL Engine Intel Inc. 4.1 INTEL-10.14.74

Blender Version
Broken: version: 2.80 (sub 60), branch: master, commit date: 2019-05-06 10:54, hash: rB064273a4ae71

Short description of error
In the outliner, there are 2 shortcuts for clicking on items. one is alt click the other ctrl click to isolate. However, there is no secondary or contra shortcut to undo isolate mode. So basically one needs to undo it manually, in big scenes this is tedious.

Another point, on OSX when you use simulation numpad, i guess, i cant alt click in the outliner because it get a scroll function. So alt click to disable in all viewport wont work.

Exact steps for others to reproduce the error
Add a cube, select it and go to the outliner. Than do ctrl click and notice that you cant undo it.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

The default keymap has ctrl as rename and alt mapped to nothing in the outliner.

Thats not exactly true, im talking about the outliner when you hover over eye icon. This is in the build from yesterday (monday 06-05-2019) See below

Another thing, it says "alt to hide in all viewports". However when i have 2 viewport without pressing alt it hides in both. It does the same with new window or new main window. So im not sure what it should do when not pressing alt???

Still can't reproduce this. I can undo the changes with ctrl+z as usual.

If is about default shortcuts, then this is a feature request and should go to https://blender.community/c/rightclickselect/

Well undo is not an solution to this. I'll make a request than.

But it's not working as the tooltip says. Not sure what alr click should do, but bidding always hides the item in all viewports.

The tooltip is totally misleading. Alt-Click hides it in all viewlayers, and also when you link the object/collection into other files, it does not affect viewports as in different 3D-viewports. And I agree that there should be the inverse for isolate.

Should i add it to rightclickselect or is big post enough?

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

The outliner logic was changed now to remove the Alt click behavior, so this bug is no longer relevant.