Page MenuHome

Switching to a Camera which is hidden, does not evaluate the animation data.
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.10

Blender Version
Broken: rB558017d6a644282cad31441867c4d96f8cb76eb4

Short description of error
Switching to a Camera which is hidden, does not evaluate the animation data.

Exact steps for others to reproduce the error

  1. Open attached blend file
  2. in the scene tab, change the camera to cam-main
  3. scrub in the timeline
  4. notice how the camera doesnt move
  5. enable viewport visibility on collection 5
  6. notice how it now moves

I reported a similar case a while back, not sure if the depsgraph has significantly changed since T51907

Event Timeline

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

Not a bug. You have disabled evaluation of the objects in that collection. So this is the correct behavior.

Sorry for reopening however I would like this to be reconsidered. The active camera 'should' have special privileges which evaluate it regardless of whether it is visible or not, as it causes much artist confusion to when the camera 'should' be animated but is not.

I would also like you to look at T51907 and realise that this is exactly the same bug. Previously, when the active camera was on a hidden layer, it was not evaluated. This is the same as when a layer is disabled.

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.