Page MenuHome

Archimesh bug
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Nvdia Gt force 580

Blender Version
Broken: blender-2.80-8f1951f555f5-win64
Worked: (optional)

Short description of error
I can't add door it gives me back a bug error message

Exact steps for others to reproduce the error
First of i'd set up the cursor and after i wanted to add the door in the create menu (shift a, archimesh) then error

Details

Type
Bug

Related Objects

Event Timeline

It works for me:


Try with the latest build and also with Load Factory Settings.

Already, i downlaoded the last build this morning! I used archimesh in my previous project. But it crashes now and i don't know why :(

i got this message

Traceback (most recent call last):

File "C:\Program Files\Blender Foundation\blender-2.80-8f1951f555f5-win64\blender-2.80.0-git.8f1951f555f5-windows64\2.80\scripts\addons\archimesh\achm_door_maker.py", line 58, in execute
  create_object(self, context)
File "C:\Program Files\Blender Foundation\blender-2.80-8f1951f555f5-win64\blender-2.80.0-git.8f1951f555f5-windows64\2.80\scripts\addons\archimesh\achm_door_maker.py", line 74, in create_object
  o.select_set(False)

RuntimeError: Error: Object '0_curve_' not in View Layer 'View Layer'!

Sometimes I get a random error. The next time I add the same object it works.
Errors from curtains: P972

i've found a solution. I don't know yet what is the problem but the addon work fine in a new project. I'll just create my doors there, copy and paste it in the other project where the addon don't work!!

I have the same error. The error comes after appending objects which are already linked in the project you append from. If you delete object you appended, it doesn't work either. You have to purge all orphan datas related to the appended object to make the add-on work again.

Brendon Murphy (meta-androcto) triaged this task as Needs Information from User priority.

hi can we have a step by step guide on how to reproduce this please?

It seems that it has been fixed in the Blender 2.80 release. I can not be sure at 100% as steps to reproduce the bug are not clear. It happened to me a few times on different projects. I tried on one of them and it seems ok.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.