Page MenuHome

Eevee not working on Intel UHD 630 / HD 620 / Iris
Closed, ResolvedPublic

Description

Operating system: Windows 10 Home 1809
Graphics card: Intel UHD 630

Broken: 2.80 (sub 61), branch: blender2.7, commit date: 2019-05-10 22:48, hash: b1af68200159, type: Release
Worked: (optional)

Eevee doesn't Show anything. Objects are invisible.

Open blender, switch to "display render preview" or press F12 for render, only a gray screen shows.

Event Timeline

Marco (nacioss) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.May 14 2019, 1:21 PM
Marco (nacioss) added a subscriber: Marco (nacioss).

Can't reproduce.. please can you send a blend file with the issue? or maybe a screenshot

Thank you for the video.. so, can you try with Load Factory Settings? Seems like your default cube has a different color/material..

Please run blender_debug_gpu.cmd from the Blender 2.80 folder, and attach the resulting files here.

for the 15 May build:

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, High.May 15 2019, 11:08 AM

Marking as high priority seems there are multiple reports about this, even if we haven't confirmed it ourselves yet.

@Jeroen Bakker (jbakker), do you have the same issue on the machine used to fix box select?

@Brecht Van Lommel (brecht) no I haven't but I can check with an official buildbot version tomorrow.

Hi there, just adding some info here, found the same issue with one of the latest builds (05-14 and 05-10).

It only happens on my notebook from work, an i3 6006u (HD graphics 520) which I use to teach at a class. Some one or two weeks old builds worked just fine.
Also tested the same builds on a gtx 970 and RX 280x, no issues there.

Can't test right now, but I will run the blender_debug_gpu.cmd tomorrow.

BUG not only affects to Eevee. Same or similar occurs with cycles engine. For reproduce with cycles you can follow the same steps.

Tanks.

Note that LookDev mode when Cycles is selected is Eevee under the hood.

Nic (WedgeW) added a comment.EditedMay 16 2019, 5:32 AM

My debug files are attached. This is from the May 15 build.

May 5th build works. May 11th doesn't. But I don't know which build is the first to exhibit the problem as I didn't download any builds between those two dates.

Incidentally, I am not experiencing the same issue when rendering in Cycles, or any mode in Workbench. Only Eevee, and only on my Surface Book 2. My home and work desktops are unaffected.

Confirmed on my laptop. So will be looking for the change that introduced this behavior.

Date 2019-05-09 v2.80.60 Hash 427c75e4c20b was the last build which eevee Works.

Brecht Van Lommel (brecht) renamed this task from Eevee not working on Intel UHD 630 / HD 620 to Eevee not working on Intel UHD 630 / HD 620 / Iris.May 16 2019, 11:46 AM

Hi,

I'm having the same problem on a Surface Pro 4...

OS Name Microsoft Windows 10 Pro
Version 10.0.17134 Build 17134
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-QDI1LVH
System Manufacturer Microsoft Corporation
System Model Surface Pro 4
System Type x64-based PC
System SKU Surface_Pro_4
Processor Intel(R) Core(TM) i7-6650U CPU @ 2.20GHz, 2208 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Microsoft Corporation 108.2318.769, 8/14/2018
SMBIOS Version 3.1
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Microsoft Corporation
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Slate
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.17134.619"
User Name DESKTOP-QDI1LVH\tedfi
Time Zone Arabian Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 6.30 GB
Total Virtual Memory 25.4 GB
Available Virtual Memory 9.08 GB
Page File Space 9.50 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Name Intel(R) Iris(R) Graphics 540
PNP Device ID PCI\VEN_8086&DEV_1926&SUBSYS_00151414&REV_0A\3&11583659&0&10
Adapter Type Intel(R) Iris(R) Graphics Family, Intel Corporation compatible
Adapter Description Intel(R) Iris(R) Graphics 540
Adapter RAM 1.00 GB (1,073,741,824 bytes)
Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\64gh6299.inf_amd64_94401bd29769cd59\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\64gh6299.inf_amd64_94401bd29769cd59\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\64gh6299.inf_amd64_94401bd29769cd59\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\64gh6299.inf_amd64_94401bd29769cd59\igd12umd64.dll
Driver Version 24.20.100.6299
INF File oem73.inf (iSKLD_w10_DS section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 2736 x 1824 x 60 hertz
Bits/Pixel 32
Memory Address 0xA0000000-0xA0FFFFFF
Memory Address 0x90000000-0x9FFFFFFF
I/O Port 0x00003000-0x0000303F
IRQ Channel IRQ 4294967286
Driver c:\windows\system32\driverstore\filerepository\64gh6299.inf_amd64_94401bd29769cd59\igdkmd64.sys (24.20.100.6299, 13.42 MB (14,073,336 bytes), 10/12/2018 11:02 PM)

First bad commit is a298dde5d799