Page MenuHome

edit mode crosshair too small to see on 4k monitor.
Closed, ResolvedPublic

Description

System Information win10 pro 64 bit, gtx 1070, 32gb ram, i7 7700k

Blender Version 2.79b

can barely see the crosshair in edit mode on a 4k monitor, windows mouse settings doesn't resolve, mouse is fine in non edit mode where windows scaling is respected.

Details

Type
Bug

Event Timeline

Please can you attach a blend file or a screenshot showing the issue? also try with the latest build from https://builder.blender.org/download/

Marco (nacioss) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.May 12 2019, 9:55 PM

Hi Marco, you can't screens shot a mouse pointer. I'd love to try the latest build, but unfortunately we're not allowed to use anything but the official build. Is there any chance you guys could update the official download so that it's the latest stable daily?

Why not a screencast? Just make a video using OBS, if you can't then use your smartphone's camera.. the latest stable 2.7 daily is the 2.7 branch, you can download it from the link i told you.

Hi Marco, screencast replaces the crosshair shown in blender with a much thicker solid white crosshair which is easy to see. In blender the crosshair appears as 4 small outer dots (one at each end of the cross), and 4 small dots in the centre of the crosshair. The outer dots are approximately 2 pixels wide, and the centre dots are approximately 1 pixel wide, which as I'm sure you can imagine is very difficult to see on a 4k screen.

Regarding the download link, we are only allowed to use the version from the official download link:

https://www.blender.org/download/

and not the experimental build page you linked to (the one that says experimental builds, use at your own risk. With main download page also states: 'not recommended for use on production environments.'

Do you have any information on when the latest stable daily will replace the official download? I notice the official download version is over a year old.

@michael campbell (3di) Try setting Large Cursors.

User Prefs > Interface > Display > Large Cursors

Hi Christopher, it's a little better, but I think the problem is the crosshair style. The dots which make the cursor up are still barely visible, particularly when there's a lot of geometry. Just to clarify, if I drag blender over to my 1080p monitor, then the cursor returns to being a solid white crosshair and is easily visible, but on the 4k screen, it turns to the barely visible crosshair which is made of 8 small dots rather than being solid lines.

What Display scaling do you have in Windows (Custom and/or per monitor, if you have more then one)?

Here's a video showing the problem

https://vimeo.com/335831398

display scaling is 150% on the 4k monitor and 100% on the 1080p display. Changing to 100% on the 4k display still shows the dot version of the crosshair instead of the solid white lines crosshair.

Marco (nacioss) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.May 13 2019, 7:02 PM
Brecht Van Lommel (brecht) lowered the priority of this task from Waiting for Developer to Reproduce to Needs Information from User.May 14 2019, 1:26 AM

@Marco (nacioss), the Waiting for Developer to Reproduce state is for when a developer is assigned.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.May 14 2019, 1:26 AM

Any ETA on someone looking at this, it's driving me nuts :)

michael campbell (3di) closed this task as Resolved.Jul 14 2019, 9:45 PM
michael campbell (3di) claimed this task.

This is fixed now in 2.8 latest build.