Page MenuHome

Timeline - Mouse cursor jumps to the bottom when scrubbing the timeline at the top
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.35

Blender Version
Broken: version: 2.80 (sub 64), branch: blender2.7, commit date: 2019-05-14 00:25, hash: rBa5b5bd2c24e0
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]

With newest version you can scrub the timeline with left mouse button at the top. But sometimes the mouse cursor jumps to the bottom now.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Insert keyframe. Scrub the timeline at the top with the left mouse button. See the cursor jumping from top to bottom and back.

Event Timeline

Confirmed. This region has wrap ON. Needs to be turn off.

(If you don't move mouse up, it won't teleport.)

George Vogiatzis (Gvgeo) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

This is not simple.
It is in the main region. Need mouse wrap there.

I am not sure this can be categorized as a bug. The behavior is not different from scrubbing in other ways, and has to do with the feature called Continuous Grab which is on by default.

It only 'teleports' if you move the cursor upwards to cross the boundary.

Supporting continuous grab is important if you want to scrub left or right to continue the scrubbing outside of the current timeline view.

It's quite easy to do by accident since the playhead is so close to the top.

Ideally continuous grab in this case would only work in the X direction, not the Y direction.

Yes, ideally it would work so that, when using the scrubbing region scrubber, continuous grab only works in the X direction. That would be nicer.

But, I am just pointing out that technically it is no different than if you scrub in other ways. It's a nice todo/task, but not sure if you could say it's a bug.

It would be nice if could keep continuous grab in Y direction for sequencer, and only block when clicking in playhead.

There are more important things, but I'd consider it a bug because you have to be quite careful not to do the wrapping by accident. Especially in an animation editor with more height than the timeline it can get annoying.

I 'll give it a try to limit Y wrap. This part should be simple.