Page MenuHome

Can't properly activate Universal Transform Gizmo
Closed, ArchivedPublic

Description

System Information
Intel Core i7, 8 Gb RAM, AMD Radeon HD 7700
Windows 7 x64
Intel Core Q6600, 8Gb RAM, NVidia GTX960
Windows 7 x64

Blender Version
Broken: 2.80, a5b5bd2c24e0
Worked: previous versions of 2.8 up to a certain point

Short description of error
Universal manipulator went missing from the recent 2.8, I can't enable it by using Shift button (in all three shortcut modes), Universal icon is missing but for some reason I can activate and use Universal manipulator by pressing Annotate button.

Exact steps for others to reproduce the error

  1. Open latest 2.8, there will be no option for the Universal manipulator so there will be no way to enable it from UI
  2. Try to enable it by using Shift or by switching boxes in Gizmos menu, it won't work despite all the boxes being ticked
  3. Press Annotate icon and it will activate Universal manipulator

Overall there is something very wrong is going on with Universal manipulator and that's is a very big problem for me because I'm working almost exclusively with it and activating it by pressing several different buttons makes it incredibly hard.

Details

Type
Bug

Event Timeline

This is not a bug, just a weak UI. Currently, any tool that includes a gizmo will override the viewport transform gizmos in the Gizmo popover.

The idea is that you could keep using the Box Select tool and then enable gizmos.

I think this works poorly. If you do use that popover to set those transform gizmos, it's slow and conflicts with the active tools, and we get these kinds of issues.

Instead, I would have rather kept the Transform tool, and added a tool option to select when dragging outside the gizmo. That would solve the main issue (ability to box select while a gizmo is active) without being this confusing and slow.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This is not a bug. The gizmos from the gizmo menu are shown, unless you have a tool that overrides them. In your case you have the Move tool selected, which overrides the gizmos. If you use the Box Select (or Annotate) tool it will show the combined gizmos.

Bit confused with this report. Don't know what the Shift shortcuts or Universal icon that missing, are.

But the tools override the Universal Transform Gizmo.
It is a known issue, that needs an improvement.

Alex (SpectreFirst) added a comment.EditedMay 14 2019, 10:53 AM

Oh, so the controls just became a lot more confusing than they used to be. And what about the dedicated button for the Universal manipulator, is it supposed to be missing as well? Oh, and I just found out that my previous report about not being able to rotate the viewport with Alt+LMB while the cursor is over the Universal manipulator is still there, for some reason it works with Move, Rotate and Scale but it starts tweaking while hovering over Universal.

I don't mind the combined gizmo being added back as a tool much, but it's definitely outside the scope of the bug tracker. User feedback goes here:
https://devtalk.blender.org/c/user-feedback

Agreed, thank you, but should I reopen my report about not being able to use Alt+LMB with Universal?

This is not a bug. The gizmos from the gizmo menu are shown, unless you have a tool that overrides them. In your case you have the Move tool selected, which overrides the gizmos. If you use the Box Select (or Annotate) tool it will show the combined gizmos.

Thanks, Brecht, for that explanation. I had just written it was a good idea the transform tool was gone (UI more streamlined now) but then I realized I couldn't find a way to turn the Move, Rotate, and Scale gizmos on at the same time. Now I see those options are in the Gizmo drop down menu, but they only show when NOT using Move, Rotate, or Scale tools which could be very confusing for users.

I propose one or both of the following tweaks to the UI:

  1. The handy little icon bar we had 2.79 let you toggle between Move, Rotate, and Scale or multiple modes by shift-clicking, or even turn off the gizmos altogether by clicking its icon. The design was very effective, and it's ultra-compactness means it could fit right in the header bar.
  1. Allow users to shift-click multiple translation tools on the toolbar. This would be just as effective as the 1st option (albeit not as compact), and automatically have the correct gizmo(s) update for the user.

I've made a screenshot below of what this might look like. Thanks so much for considering this!