Page MenuHome

Numpad functionality and inset not functioning as previous version
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10 Education 1809
Graphics card: GTX 1050ti and GTX 680

Blender Version
Broken: blender-2.80-a5b5bd2c24e0-win64, as found on the splash screen
Worked: blender-2.80-d966c2f0c2ad-win64

Short description of error
I can't inset a plane along all 4 edges, just across the x or y after extruding it. the z won't adjust.
I was advised that if I used CTRL and A and Apply Scale it would work, but this just shrinks my cube to a very think rectangle along the Z.

Also, I'm having issues with numpad 1,2,3,4,6,0 not altering views.

Video of issue here: https://www.reddit.com/r/blender/comments/bo8epv/does_anyone_know_why_blender_wont_inset_all_four/?utm_source=share&utm_medium=ios_app

Exact steps for others to reproduce the error
See an attached .blend file.

Details

Type
Bug

Event Timeline

Works as expected here. Apply scale (Object mode -> Ctrl+A -> Scale), then inset treats all axes the same.

To help you understand what is happening better:

  1. in the Properties editor, go to the Object tab and look at the scale x/y/z fields.

Your object is scaled by 19.9 on the x- and y- axes, and 1 on the z.
That means your object is as tall as it "really" is, but 19.9 times wider than it "really" is.

  1. Now change the x and y scale values to be 1.

Now you see your object as it truly is: very thin, very tall.

  1. Now try to inset.

The face scales evenly from all edges, as you'd expect.

  1. Finally, change the x and y scale values back to 19.9.

This is the result you were seeing before. You'll notice that Blender was handling your mesh correctly but, due to the non-uniform scale, you were seeing a distorted version of it.

As for the numpad keys not working correctly, your view is very zoomed in. With your object selected, press "." on the numpad to reset the zoom level and centre on the object. You should then be able to rotate the view more easily.

I think this can be closed as not a bug.

Sebastian Parborg (zeddb) closed this task as Archived.Jun 11 2019, 5:12 PM
Sebastian Parborg (zeddb) claimed this task.