Page MenuHome

Header buttons showing on top of Tool Settings bar
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-4.15.0-47-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 410.73

Blender Version
Broken: version: 2.80 (sub 64), branch: blender2.7, commit date: 2019-05-14 22:59, hash: rB4e46ed37fc59
Worked: (optional)

Description of error
Some buttons of the 3D View header are overlaping the Tool Settings bar, cutting it in half and negating a lot of space that may be needed for active tools that require such space.
It also creates conflicts when flipping the header to the bottom of the 3D View, as these buttons stay inside the Tool Settings bar, regardless of the rest of buttons.
This doesn't happen with the other header buttons like the current object mode, menu buttons, object type visibility, viewport gizmos, viewport overlays and shading buttons.

Current state of the Tool Settings bar

How it should be.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This was by design, it gives more space in the 3D viewport. For this kind of feedback you can go here:
https://devtalk.blender.org/c/user-feedback

The other reason it works this way, is because on smaller displays there will then be enough space for all the items in the header.

Plus the fact that these controls really are actually tool settings.