Page MenuHome

Eevee doesn't show reflection correctlyh with SSR, refraction and Reflection Plane
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro x64
Graphics card: GTX 1060

Blender Version
Broken: blender-2.80.0-git.27d097e92d54-windows64, blender-2.80.0-git.ebc44aae9897-windows64

Short description of error
Eevee doesn't show reflection correctlyh with SSR, refraction and Reflection Plane.
There are two problems.

  1. Eevee doesn't update reflection image correctlyh with SSR, refraction and Reflection Plane. You can solve it using Blend Mode option set to Alpha Blend in the material of reflected plane (E.g. water).
  2. There are artifacts like a ghost in reflection of objects on the plane. You can also solve it using Alpha Blend and Show Backface option in these objects though...

Exact steps for others to reproduce the error
See attached image and sample blend file please.



Thanks,

Event Timeline

matc (matc) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.
matc (matc) added a subscriber: matc (matc).

I can confirm Alpha Blend fixes the ghosting. But Show Backface appears to be optional.

Enabling Backface Culling for the water plane fixes the ghosting too. Although this can be broken by adding a Solidify modifier to plane.

Thank you for confirming, matc.
Yeah Backface Culling should'nt be necessarly for this in latest builds (at least 079c7f918c81). And I also verified that Blender works wrong to update faces made by Solidfy modifier.

Satoshi Yamasaki (yamyam) reopened this task as Open.EditedJun 7 2019, 4:12 AM

Hi Clément, Thank you for the fix. But unfortunately, the ghost problem is still there...(verified with blender-2.80.0-git.aa003c73245f-windows64)

Ok, you can avoid them with Alpha Blend setting in reflected object. So is it proper behavior or one of the limitation of Eevee?

Clément Foucault (fclem) closed this task as Resolved.Jun 7 2019, 2:04 PM

The artifact is because the Screen Space Refraction does not know what is behind the suzanne or the red cube. Using Alpha Blend removes the objects from the prepass so refraction is done before rendering these objects. This could be an option for all shaders in the future but for now it is a limitation.

Also in the future try to report one bug per ticket. :)

Thank you for the detail. I (and maybe other users) don't know what is limitation or not, so such imformation is very useful!

Also in the future try to report one bug per ticket. :)

In this case, I thought they're related things. sorry for the complicated report...

Anyway, thank you for the fix again!