Page MenuHome

EEVEE Viewport render: multisampling is ignored when drawing object lines
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits

Blender Version
Broken: version: 2.80 (sub 69), branch: blender2.7, commit date: 2019-05-17 23:36, hash: rB03672e77836d

Short description of error
Viewport Samples set on 1,
Here is screenshot of actual viewport

And render result:

Exact steps for others to reproduce the error
Set multisampling to 4+, open file, and render viewport:

There is two variants: using multisample settings for lines to have viewport render as is or use common viewport samples from render settings to have solid control. I prefer the second one.

Event Timeline

Not a Bug: I'm pretty sure you need to enable the Viewport anti-aliasing for it to work. Check my post history, I created an issue about this, that's when the Viewport quality setting was replaced with the Viewport anti-aliasing setting. Still no idea what the Multisampling setting affects, though.

Viewport samples only affect the workbench part. The lines are drawn by using the Multi sample setting. During viewport rendering the lines are currently drawn if the setting is set to no multisample. I am not sure that if the cause of this is a technical limitation. Will need to investigate why MSAA is not used.

Jeroen Bakker (jbakker) renamed this task from EVEE Viewport render: viewport samples or multisampling is not influence to quality of lines to EEVEE Viewport render: multisampling is ignored when drawing object lines.May 20 2019, 12:24 PM
Jeroen Bakker (jbakker) claimed this task.
Jeroen Bakker (jbakker) triaged this task as Confirmed, Medium priority.
Jeroen Bakker (jbakker) closed this task as Resolved.May 31 2019, 12:58 PM