Page MenuHome

Eevee Artifact Shadow Cube Size < 256px
Closed, ArchivedPublic

Description

System Information
Operating system:
Windows 10 version 1809
Graphics card:
GeForce GTX 960 driver version: 388.13
Blender Version
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
2.80 Beta, f606f588455e, 2019-05-20 06:52
Worked: (optional)

Short description of error

Vertical artifact appears on unicorn when using Eevee shadow settings:
Method: Any
Cube Size: 64px larger artifact, 128px smaller artifact, < 256px OK. Started messing with it because of a zigzag lighting pattern which I figured was an algorithm setting.
Cascade Size: Any
High BitDepth: Any
Soft Shadows: Any
Light Threshold: Any

Exact steps for others to reproduce the error

Hit F12

Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Clément Foucault (fclem) closed this task as Archived.Jul 1 2019, 8:47 PM

This is an issue with filtering and the fact that only very few pixels covers the objects in the shadow map. Lower shadomap resolution is more prone to shadow acne.

Unfortunately it is a limitation of the current shadow mapping implementation. To avoid this artifact, increase the shadow map bias parameter on the Light object.