Page MenuHome

Action Constraint misinterpreting y rotation of action
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10 (version 1809)
Graphics card: nvidia GTX 960

Blender Version
Broken: 2.80, 9efe117535c6, win64, 2019-05-20

Short description of error
When using an action constraint, it misinterprets the y rotation (of a quaternion at least) and uses the negative rotation instead.
For example, when the y rotation in the action itself is -0.121, the action constraint interprets it as 0.121 and applies it as such

Exact steps for others to reproduce the error
Armature with action constraint
see attached file (rescale the green bones - they are the targets for the action constraints)

Details

Type
Bug

Event Timeline

i figured out the issue, and this isnt happening due to the action constraint, but the copy rotation constraint, which seems to flip the y rotation, even if the target bone is in its base rotation...

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Is this solved now perhaps? I don't seen anything obviously wrong when scaling the green bones in the test file.

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

Same here, seems to be working fine. Also no response in a long time, so, closing.