Page MenuHome

Inconsistent viewport display of Stroke objects with visual effects
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: AMD Radeon R5 M335 ATI Technologies Inc. 4.5.13497 Core Profile Context 23.20.768.12

Blender Version
Broken: version: 2.80 (sub 71), branch: blender2.7, commit date: 2019-05-20 22:03, hash: rBe78770039397
Worked: (optional)

Short description of error
Stroke objects with visual effects display in the viewport very inconsistently. Merely panning around makes them look different every time. Rendered results don't match viewport display either. Overall, effects are very awkward to use.

Exact steps for others to reproduce the error

  • Create a new file, choosing the 2D animation workplace
  • Start drawing
  • On the Object visual effects tab, choose any effects, for example, Wave Distortion
  • Hit Z, choose render view (8) from the pie menu.
  • Try panning around by holding Shift+Middle Mouse Button. Notice how the wavy effect keeps changing every time you move.
  • Try rendering. The render result looks nothing like what you see in the viewport.

Details

Type
Bug

Event Timeline

vunhughvaw updated the task description. (Show Details)
vunhughvaw updated the task description. (Show Details)
vunhughvaw updated the task description. (Show Details)May 21 2019, 3:21 PM
Brecht Van Lommel (brecht) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.

The FX are working in Screen Space, so any change in the viewport or camera angle will change the final result. Really, FX will work as compositor using the final render/viewport image and apply a filter on it. If you chnage image, you get different result.

I don't think we can do more here, because in future releases this will be replaced by new compositing features, but now all is pending of design.

The FX are working in Screen Space, so any change in the viewport or camera angle will change the final result. Really, FX will work as compositor using the final render/viewport image and apply a filter on it. If you chnage image, you get different result.
I don't think we can do more here, because in future releases this will be replaced by new compositing features, but now all is pending of design.

I'm pretty sure the screen space is also what causes issues in the rendering too; the rendering screen space is cutting off a bit of the visual effects. I was thinking if a code that makes a little bit of a *screen clearance (a few pixels over the desired size) and then cropping to the desired size after the entire render would be possible.

Brecht Van Lommel (brecht) closed this task as Archived.Jul 8 2019, 3:05 PM