Page MenuHome

Grease Pencil: Blender crashes immediately after invoking frame interpolation.
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.2.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) Iris(TM) Graphics 6100 Intel Inc. 4.1 INTEL-12.2.17

Blender Version
Broken: version: 2.80 (sub 71), branch: master, commit date: 2019-05-20 22:03, hash: rBe78770039397
Also broken: version: 2.80 (sub 60), branch: master, commit date: 2019-05-06 20:33, hash: rBddb71e8c20c2
Worked: (optional)

Short description of error
Grease Pencil: Blender crashes immediately after invoking frame interpolation.

Exact steps for others to reproduce the error
Crash in Grease Pencil Animation Draw Mode: Grab 2 Keyframes and go to frames/interpolate/sequence – crash.

Details

Type
Bug

Event Timeline

I can't reproduce this problem on today's build hash: 21d065af5d70 it works without problems.
Perhaps this just changed today - but it is not located in Frames > Interpolate > Sequence, but instead in the 3D view in Strokes > Interpolate > Sequence.
I drew a stroke on two frames, moved the current frame in between and called interpolate sequence. I tried this both on an Intel UHD 620 and an NVIDIA 1060 GPU just to be sure.

Does your crash occur when doing only these simple steps, right after starting Blender? Or is there more going on in your scene?

Okay, it doesn’t crash with a fresh scene. But oddly, I only have some strokes and a background movie in the scene, nothing else. I re-used the scene setup from another scene in that I duplicated it and started editing the duplicates. Does this make any difference?

Thank you for the quick reply. It might make a difference, hard to tell. But it is important for a developer to be able to reproduce the bug. So what you could try is to build the same scene from a new empty file, because you said it's quite simple. Try to add the background movie and test, then add similar strokes and see if that was the cause for the crash.

It is ideal if the crash can be reproduced with as little steps as possible. If you can't get the crash to happen again, you can always post the problematic blend file. You can also try to step by step remove things from the problem file until almost nothing is left and after each step try to see if the crash still happens. This will maybe help to pinpoint the problem. Perhaps the background movie is causing problems? Don't know but worth trying when the movie is removed from the scene.

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

We need a .blend file and steps to reproduce the issue, otherwise we can't investigate this.

Okay, I can provide a .blend file soon – as soon as I met my project deadline ;) I’ll get back to you!

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

I feel like it'd make sense to temporarily close this so it doesn't attract triager eyeballs. When your project deadline has arrived and you're able to provide the .blend file, you should feel free to reopen this task. (Add Action->Change Status->Open).