Page MenuHome

Shading Viewer Node broken with Transmission, Subsurface and Clearcoat
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 480/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 391.35

Blender Version
Broken: version: 2.80 (sub 71), branch: blender2.7, commit date: 2019-05-20 22:03, hash: rBe78770039397
Worked: version: 2.80 (sub 66), branch: master, commit date: 2019-05-16 12:17, hash: e60890075b37

Short description of error
When using node wrangler "Viewer Node" with material containing either Transmission, Subsurface or Clearcoat, the render breaks.

Exact steps for others to reproduce the error

With Node Wrangler Enabled

  • Create material with transmission
  • Switch to Rendered View
  • Add a new node and preview it with a Viewer Node.

or

  • Open file
  • Switch to rendered view

Details

Type
Bug

Event Timeline

rndmnm created this task.May 21 2019, 8:47 PM
rndmnm added a project: Add-ons.

Update: It seems to be fixed for Clearcoat and Transmission, but still broken for subsurface.

rndmnm closed this task as Resolved.May 31 2019, 1:49 PM

Seems to be fixed, I assume by rB596492e639f0, 'cause visually the issue was pretty similar.