Page MenuHome

Scene fails to render if object is deleted
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.71

Blender Version
Broken: version: 2.80 (sub 71), branch: blender2.7, commit date: 2019-05-20 22:03, hash: rBe78770039397
Worked: (optional)

Short description of error
This is a test of animation performance on instance heavy scenes. The animation renders fine until frame 90. After frame 90, every frame renders blank (save for the Z-depth). A cube was added to the master Scene Collection and once this was done, the scene renders again. However deleting the cube results in the scene no longer rendering.

Exact steps for others to reproduce the error
Load the .blend file.
Press F12 to render. The image viewer will pop up and you will see a landscape.
Delete the Cube object.
Press F12 to render. The image viewer will show a blank image.
Add a new Cube object.
Move it to the root Scene Collection.
Press F12 to render. The image viewer will pop up and you will see the landscape again.
Repeat over and over.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) closed this task as Resolved.
Sebastian Parborg (zeddb) claimed this task.

I can't reproduce this on my end with the latest beta.

So I think this might have been solved at some point.

If this is not the case and you can still reproduce this, let me know and we'll reopen this.

Thanks! I tried with the latest build and could not reproduce it, so I think it's resolved.

Cheers!