Page MenuHome

Inconsistent OPEN ON MOUSE OVER menu behavior
Closed, ArchivedPublic

Description

System Information
Operating system: WinPro10 64b i7 32ram 3TB-SSD
Graphics card: Nvidia GTX1080 (Alienware15R3)

Blender build (latest May 23)
blender-2.80.0-git.a1ad71304c2d-windows64

2.80 UI will freeze soon, yet some menus still don't open on mouse over. Possibly unfinished work. I file this not as Bug but To Do.

ISSUE: with Preference>Interface>Menu> Open on Mouse Over turned on, many menus of the same type don't open at all.

  • Transformation Orientation
  • Object/Edit/Pose/Weight Paint etc etc modes
  • Pivot Center options
  • Proportional Editing options
  • Editor type per window

Other frequently used candidates for Open on Mouse Over are still consuming redundant clicks.

  • T Toolbar buried items in most modes
  • Animation>Dopesheet, Nearest Frame
  • Properties>everything that will drop down or drop up: Surface, Base Color, Modifiers, Constraints etc

The above falls under INCONSISTENT implementation.

The following are related additional suggestions.

Other candidates as Interface> Menu> Open Mouse on Mouse Over OPTIONS

  • OUTLINER to expand one hierarchy by time out
  • TAB>Mini Tool Shelf to expand by time out
  • PROPERTIES Editor>submenus to expand by time out, and re-collapse within a time out window (imagine that)

Maybe 2.81?

As a multi-app middleware user I am very very grateful for this Open on Mouse Over feature. It is a super click-saver and definitely wrist-saver. Thank you all.

Details

Type
To Do

Event Timeline

The Yzar (Goldiva) updated the task description. (Show Details)

I don’t think this was ever supported by anything other than pulldown menus. The issue is that, if it were enabled for enums and popovers, you would easily open then accidentally when just navigating over the Properties editor, for example.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Arguably it could be made to work for popovers and enums in headers. But this kind of feedback is not for the tracker, but here:
https://devtalk.blender.org/c/user-feedback