Page MenuHome

Wireframe Shading in Edit Mode is a Semi Transparent White Since Yesterday's Shading Update.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 LTSC v1809 Build 17763.504
Graphics card: GTX 970 (418.81 WHQL)

Blender Version
Broken: blender-2.80, caf52e3779a9-win64
Worked: (optional)

Short description of error

Wireframe Shading in Edit Mode is a Semi Transparent White/Grey Since Yesterday's Default Shading Update. (It used to be darker?)

  1. No changes to Wireframe Shading in Object Mode.
  2. Happens in both Solid & MatCap Shading Modes.
  3. Adjusting X-Ray Slider to 1.0 doesn't seem to make it fully transparent as before either.
  4. Turning on/off the new Edge Highlighting in Edit Mode doesn't seem to make any difference.
  5. X-Ray Select Through works as usual.

It seems like some sort of a white overlay being drawn only when in Edit Mode? Because even with Solid/MatCap shading in Edit Mode. The surface looks brighter compared to Object Mode. Kind of like a Lighten/Screen Filter in Photoshop. Not sure if this was intended, but thought I'd report it cause it felt very distracting when using on a more complex mesh. Very bright and dithery compared to the darker, more transparent version before this change. :)

Thanks for all the hard work guys. Cheers.

Exact steps for others to reproduce the error
(Attached Video)


Opaque faces in wire also make more dense meshes much harder to see:


The increased alpha also causes issues with UV unwrapping since you can't see the underlying texture as well, comparison of 2.7x and 2.8x.

The opacity is so high that pure black in this example is closer to white then black.

The same mesh as wire.

Higher opacity makes face-dots harder to see, the white also looks like it could be a highlight when it's not.

Details

Type
Bug

Event Timeline

Campbell Barton (campbellbarton) triaged this task as Confirmed, Medium priority.Sat, May 25, 4:02 PM

Caused by rB203f9a49e29c82458a49efe856eb58f938eb537b

Agree this isn't an improvement, it seems all tests were done with a fully shaded mesh, not wireframe.

  • Un-selected color is opaque enough to get in the way of the wire behind it.
  • The white color of un-selected faces looks a bit like a highlight.
Campbell Barton (campbellbarton) raised the priority of this task from Confirmed, Medium to Confirmed, High.
Campbell Barton (campbellbarton) updated the task description. (Show Details)

Thanks for confirming Campbell. And also for the before and after comparisons. I didn't have a build from before to compare with. --- Agree, It makes it very distracting when working on dense meshes trying to select through.

PS: Hope the video played alright, cause on my end it played twice and now it says, "No video with supported format and MIME type found." I can re-attach if needed. Cheers.

Not sure if this is the actual cause/fix for it. But when you mentioned Alpha, made me think it might be related to theme settings. :)

Theme Settings > 3D View > Face seems to have an Alpha value of 0.129. Changing it to "0" seems to have done the trick.

This seems to have brought the old darker/transparent look back. But I've got no way to compare with an older build. Hope this helps. Cheers.

Wireframe (Object Mode) - Lines seem much clearer & contrasted.

Wireframe (Edit Mode) - Lines seem faint & noisy. Kinda like looking through a mesh filter. Not sure if its an Anti-Aliasing thing. AA is set to Default (8 Samples)

Cause I remember Edit Mode Wireframe used to be sharper? Even with new Edge Highlighting On, front facing edges are bolder, Yes. But occluded edges are quite faint.

Well the white face overlay is design to give more contrast and I can tell you that's what it does. But I agree opacity maybe a little too high when considering multiple layers.

Opaque faces in wire also make more dense meshes much harder to see:

I beg to differ. The right example is much more readable.

The increased alpha also causes issues with UV unwrapping since you can't see the underlying texture as well, comparison of 2.7x and 2.8x.

The opacity is so high that pure black in this example is closer to white then black.

Yes. But this drawback can be counter workaround by disabling the edit face overlay in the overlay panel.

Higher opacity makes face-dots harder to see, the white also looks like it could be a highlight when it's not.

I agree we could lower the opacity of unselected faces. Maybe do something special for wireframe mode but I don't really like that idea.

@William Reynish (billreynish) do you have any opinion?

Well the white face overlay is design to give more contrast and I can tell you that's what it does. But I agree opacity maybe a little too high when considering multiple layers.

Thanks for clarifying Clément. When I look at it from that perspective, Sure. I can see it as a perk. Especially when using Edit Mode with Edge Highlighting = Off for better visual clarity in Vertex/Face select modes. Since the edges are much dimmer in those modes, the overlay does seem to help to still keep them visible and relevant without being lost in the dark grey of the viewport backdrop. Could definitely use some tweaking though. 0.129 value does seem a bit overpowering. :)

Also, that weird grainy/noisy "Overlay" look when in Wireframe mode was making the see-through aspect of it very distracting to read. Especially in denser meshes. --- Was wondering what caused it, so went on to try all different AA modes up to 32 samples with no change. --- Under viewport shading options, changed Xray value from 0.5 to 0.0 and voila. A nice clean, crisp and readable overlay appeared. :) Not sure why the Xray value was giving that noisy, sand-paper like look to the Wireframe Mode overlay. Or even if it was intended or not. But here's how it looks with both values. Hope it makes sense. :)

Wireframe Mode: Xray 0.5, Alpha: 0.129

Wireframe Mode: Xray 0.0, Alpha: 0.129

Wireframe Mode: Xray 0.0, Alpha: 0.071

Wireframe Mode: Xray 0.0, Alpha: 0.129, Value: 0.5 (Even tweaking the Value, we might be able to find a happy medium?)

I apologize if this is a bit off topic but let me second Gibran when it comes to the grainy / noisy overlay. In wireframe + edit mode, I personally feel that it is very distracting especially when working with planes as images behind the model.

While the stippling of x-ray mode isn't a new issue, it's much more distracting/noisy with the newly increased alpha.

Anything against setting the x-ray alpha to zero?

The setting is separate from solid mode, where some alpha is necessary.

Oh, I wasn't aware that they are different between solid mode and wireframe mode. In that case, I support setting the wireframe mode's x-ray alpha to zero unless there is a better solution.
Ideally of course there would be a solution that keeps the softness gained from the alpha whilst removing the noise.

Though I guess most of this comes down to personal opinion so this is just my take on it.

Agreed. The grainy/noisy look of the Xray when in Wireframe wasn't really noticeable (didn't bother much) until the changes to the Alpha. I actually thought it was due to Anti-Aliasing. But later realized it was related to the Xray value in shading options. :)

In defense of the changes made to Alpha. I do get it. Especially with the new Edge Highlighting mode, it does help keep the mesh and edges stay visible and not get lost in the dark grey of the viewport background when in Vertex/Face select modes.

I'm cool with anything you guys decide as a default. As long as we have the option to set it to preference. Xray value and Face Alpha being those options. Thanks for all the hard work 'n have an awesome week guys! :)

Clément Foucault (fclem) closed this task as Resolved.Mon, May 27, 1:54 PM

We made the alpha lower and made the xray slider zero in wireframe mode.

Related commits: rB8cfd46a5b00b rB5241dd1daf1c

Yeah, Noticed those on today's commit log. Thanks Clément. Appreciate it. :) Keep up the good work mate. Cheers.