Page MenuHome

GPencil Eevee render always set meshes in front
Closed, ResolvedPublic

Description

Last source code compiled on Windows 10 64bits at 25/05/2019 10:50:00

Open the task to keep note of the bug I was talking in the chat with @Clément Foucault (fclem)

The error looks related to the last changes in Draw Manager because grease pencil code was not changed.

In the image below, viewport on the left and render result on the right.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) updated the task description. (Show Details)
Antonio Vazquez (antoniov) triaged this task as Confirmed, High priority.

@Clément Foucault (fclem) Let me know if you need any help.

Antonio Vazquez (antoniov) renamed this task from GPencil render always set meshes in front to GPencil Eevee render always set meshes in front.May 26 2019, 4:51 PM

I have checked and the problem is only in Eevee

I added a grease pencil test to the render regression tests, to catch this kind of issue in the future.
rBL62241: Tests: add grease pencil render test

Here a simple test file (very small to make debug easier) with a monkey in front of a cube.

I have done a debug, and the z-depth of the Cube is negative, so as it's lower than GP object z-depth, is put in front.

@Clément Foucault (fclem) is normal to have a z-depth of -13 when the GP object is in front and have a z-depth of +13?

Clément Foucault (fclem) closed this task as Resolved.May 27 2019, 1:22 PM

Fixed by rB24ac97062439 thanks for debugging :)

@Clément Foucault (fclem) I still has the problem with a more complex file.

Try this: