Page MenuHome

Eevee: ludicrous high value fireflys AO+Bent normals
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.35

Blender Version
Broken: version: 2.80 (sub 72), branch: master, commit date: 2019-05-24 18:32, hash: rBa629c74c9cd8
Worked: (optional)

Short description of error
Seems that in that angle from the camera those objects align in order to generate the fire flies in the object "AA-Rojo_Interior" the SSS spread the firefly all around thats why i leave SSS to 1 in all the objects in the sample.
Turning off bent normals in the AO options or removing the normal map from the material "GrisPlastico" seems to "fix" or avoid the issue.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]


1-Switch to viewport render
2-scrub the timeline, around frames 220 - 230

Event Timeline

I can replicate it in the sense that they happened to me in some frames of an animation but I couldn't pinpoint what angles point of view caused it. All that I can confirm is that they happened with AO+Bent normal + Subsurface. It was force to fix this using the Compositor to clamp the high values, erase the alpha and use the Inpaint filter.

My system is Nvidia 1060 6gb, Windows 10 64bit

Brecht Van Lommel (brecht) triaged this task as Waiting for Developer to Reproduce priority.Fri, May 31, 7:05 PM

I cannot reproduce it here on my setup (linux + AMD Radeon Pro + mesa).

Maybe it's a driver bug on windows 7? Can anyone confirm that?

We tried to reproduce this issue but were not able to.
Could you try to update your graphical drivers and test with the latest blender?

ok, ill try to test this further, ill try to do it as soon as i can

Ok i have done more tests.
in my main machine (i7 win7 gtx 1070 ), updated drivers (430) an last blender version and the bug its consistently appearing always there.

Then i undust my old secondary machine a q9300, win7, nvidia 460 (updated drivers 354), and there the bug didn't appear. . . . nothing, works fine as it should.

So there is a problem i can see it in my main machine but i totally understand if this report its closed as "not enough info" or "not able to reproduce" since im with both machines same file in front of me, i can't get consistent behavior.

Ill keep an eye open in case i find any other clue to reproduce the error more consistently.

Can you pack the normal map inside the file?

DANG! ok im feeling really really stupid right now, i though i had paked, and i was sure when was moving a file that weight more than an 1mb with only that little mesh data. . . . anyways, ill test this again in my secondary machine later to check this version.
Its kind a bit big but this is the file with the normal map.

I tested the fix with 8fa65ed31b7f and 8b2b79c2108b and the viewport looks great and mainly worked but. .

https://youtu.be/FUpuVy0LRTU

The problem seem to persist but in a different frame and a lot fewer, one more difficult thing its that its not possible or at least i wasn't able to reproduce with the demo .blend i uploaded later, so im going to disect the scene again to try to prepare another demo file to test it.

I was just commenting here to let you know.

By the way, what should i do if i can pin point a demo .blend reproduce the error? should i added here or create a new bug report?
Thanks

Yes just attach the blend file here.


In this file i got a consistent result

1 open
2 render

Changing anything makes the firefly don't appear.
For example:
-render size 1920x1079 instead of 1920x1080.
-less than 89 render samples.
-frame number

Tested with builds 8b2b79c2108b and aa003c73245f

Unfortunately I cannot reproduce this time. I tried a blind guess and maybe it will fix the issue.

Hi, i have test with 4fb441517251, rendered that problematic shot a few times with different sizes and also other cameras, that blind guess seems to be working i didn't see any fire fly, this scene shots are rendering properly now.

Thanks

Clément Foucault (fclem) closed this task as Resolved.Sat, Jun 8, 11:59 AM