Page MenuHome

Intel HD Graphics bone selection problems in edit mode/pose mode
Closed, ResolvedPublic

Description

Operating system: Windows 10
Graphics card: Intel HD

Broken: 2.80, f18373a9ab1a, master, 2019-05-25

  1. add armature - single bone
  2. go to edit mode
  3. select all
  4. subdivide bone into 2 cuts
  5. deselect all
  6. try to select bones other than the root. (can't select them or their heads)
  7. go to pose mode and the same thing happens

Details

Type
Bug

Related Objects

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.
  • Please try installing the latest graphics drivers from the Intel website if you haven't already.
  • If that doesn't help, please attach the output of Help > Save System Info, so we can see which specific Intel card and driver version is being used.
Brecht Van Lommel (brecht) claimed this task.

Assuming this was fixed along with T65066: Armature and bone selection is broken on macOS, if not we can reopen the report.

Hi Brecht,

I'm still having this issue with the recent builds (after I've seen this problem was resolved in MacOS). I already updated my driver. Attached is my system info. T{F7081773}hanks

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

I have the same issue with an Intel(R) HD Graphics 4000 Intel 4.0.0 with the latest drivers installed.

Exact same problem here ! Intel I3-3220, internal HD Graphics, 8GB DDR3. A work around this problem:
Display the bones in WIRE mode, then they can be selected without problems. If OCTA,ENVELOP, BOX is choosen then they CAN NOT be selected.
Other workaround this that works in POSE only: Using SHAPES ( Custom Bones ) , bones that have custom shapes can be selected. However in Edit mode there is not custom shape representation, so problem persists. Best OPTION: Display as wires and add custom bones to all bones in the armature.
Obviously this does not happen in 2.79b and before,
Regards !

This should be fixed in the 2.81 daily build I think.
https://builder.blender.org/download

Philipp Oeser (lichtwerk) lowered the priority of this task from Normal to Needs Information from User.

Hi everyone, I am going over bone selection reports atm. (there are a couple T68042, T66950, T67208, T69233, T68574).

Since I cannot reproduce this one (on rBf88022b96f3a), I'd like to know if this is still an issue?
Please report back so we can get bone selection sorted once and for all... thx in advance!

hi, yes it's still an issue, even on latest builds. thanks

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Normal.

so summing up on the Intel drama, we have:

@Makahiya Dimakausap (moonshutr7) : renderer 'Intel(R) HD Graphics', vendor: 'Intel', version: '4.0.0 - Build 10.18.10.5069' (cannot tell what model that actually is...)
@Harris Smith (Harris3D) : Intel I3-3220 (Ivy Bridge) : strictly speaking: GPU not supported (see here)
@james hollingham (jameshollingham) : HD Graphics 4000 Intel 4.0.0 - Build 10.18.10.4358 (Ivy Bridge) : strictly speaking: GPU not supported (see here)
@Rohit (Rohit624) : intel hd graphics [no more information provided, likely unsupported GPU as well...]
@sineo (sineo) : Intel(R) HD Graphics 4000 Intel 4.0.0 - Build 10.18.10.4358 (Ivy Bridge) : strictly speaking: GPU not supported (see here)

still confused about the driver build numbers tbh, I can see 10.18.10.5069 being pretty recent, however the build numbers here https://downloadcenter.intel.com/product/80939/Graphics-Drivers are not anywhere near...
(has anyone tried the ones from the intel site?)

quoting from https://code.blender.org/2019/04/supported-gpus-in-blender-2-80/

Intel graphics for Haswell and newer are supported and generally working well.
See the list of Intel GPUs to check which architecture your processor has.
There are a few bugs planned to be fixed still, related to selection and reflections in Eevee on specific graphics cards.

@Clément Foucault (fclem): not sure if this selection problems planned to be fixed include this reported issue here (and if that would work on these non Haswell GPUs)?
Anyways, since these GPUs are below the minimum requirements for Blender 2.80, shall we close this now...?

Philipp Oeser (lichtwerk) renamed this task from Can't select bones in edit mode/pose mode in viewport to Intel HD Graphics bone selection problems in edit mode/pose mode.Wed, Aug 28, 6:16 PM

It's already resolved (at least in my computer) in the latest 2.81 build (2019-9-11).

Glad to hear, thx for reporting back...

I was having the same issue as described by the original poster. This issue was happening for me in blender 2.80 official release but is no longer happening in the later development builds for 2.81. Also, the issue is not present using 2.79, but of course, I hope I don't have to use that anymore!

Thank you for keeping blender working great! I hope this fix continues into the new official release!

It's already resolved (at least in my computer) in the latest 2.81 build (2019-9-11).

how to fix sir?