Page MenuHome

Animation not rendering
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.39

Blender Version
Broken: version: 2.80 (sub 71), branch: blender2.7, commit date: 2019-05-22 21:50, hash: rBa1ad71304c2d
Worked: Official 2.79b

Short description of error
Animation works in camera viewport but not in rendered version

Exact steps for others to reproduce the error
Render animation in eevee or cycles

Details

Type
Bug

Event Timeline

William Reynish (billreynish) triaged this task as Needs Information from User priority.

This report is too vague. We will need a blend file and specific steps to reproduce.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.
William Reynish (billreynish) triaged this task as Waiting for Developer to Reproduce priority.May 26 2019, 9:26 PM

Cannot reproduce any issue with this file. It seems to render normally and animation playback works.

Brecht Van Lommel (brecht) lowered the priority of this task from Waiting for Developer to Reproduce to Needs Information from User.

Please try the latest build, there have been some bugfixes related to render crashes after May 22.

I have just downloaded the latest build and the problem persists. I have made a simpler model to illustrate. The model is a beam engine which is animated by a simple driver script on the flywheel. The animation runs fine in the viewport but when rendering the animation the piston rod which uses a number of constraints on the "piston rig" does not move. When billreynish said the file appears to render normally I suspect he may not have noticed the small detail of the piston rod. It is more noticable in this simpler file,


To reproduce the problem activate the animation in the view port (it runs without problems here) then render the animation and the piston rod does not animate, at least for me as per this file

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.May 29 2019, 1:49 AM
Sebastian Parborg (zeddb) closed this task as Archived.
Sebastian Parborg (zeddb) claimed this task.

It is broken because of a dependency cycle:

Dependency cycle detected:
  OBPisron/Transform Component/TRANSFORM_INIT() depends on
  OBPistonRig/PistonBone/BONE_DONE() via 'Bone Parent'
  OBPistonRig/PistonBone/BONE_READY() via 'Ready -> Done'
  OBPistonRig/PistonBone/BONE_CONSTRAINTS() via 'Constraints -> Ready'
  OBPistonRig/PistonBone/BONE_POSE_PARENT() via 'Pose -> Constraints Stack'
  OBPistonRig/LinkBone/BONE_DONE() via 'Parent Bone -> Child Bone'
  OBPistonRig/LinkBone/BONE_READY() via 'Ready -> Done'
  OBPistonRig/LinkBone/BONE_CONSTRAINTS() via 'Constraints -> Ready'
  OBPistonTarget/Transform Component/TRANSFORM_FINAL() via 'Locked Track'
  OBPistonTarget/Transform Component/TRANSFORM_SIMULATION_INIT() via 'Simulation -> Final Transform'
  OBPistonTarget/Transform Component/TRANSFORM_EVAL() via 'Transform Eval -> Simulation Init'
  OBPistonTarget/Transform Component/TRANSFORM_PARENT() via 'Eval'
  OBPistonTarget/Transform Component/TRANSFORM_LOCAL() via 'ObLocal -> ObParent'
  OBPistonTarget/Transform Component/TRANSFORM_INIT() via 'Transform Init'
  OBPisron/Transform Component/TRANSFORM_FINAL() via 'Parent'
  OBPisron/Transform Component/TRANSFORM_SIMULATION_INIT() via 'Simulation -> Final Transform'
  OBPisron/Transform Component/TRANSFORM_EVAL() via 'Transform Eval -> Simulation Init'
  OBPisron/Transform Component/TRANSFORM_PARENT() via 'Eval'
  OBPisron/Transform Component/TRANSFORM_LOCAL() via 'ObLocal -> ObParent'
  OBPisron/Transform Component/TRANSFORM_INIT() via 'Transform Init'
Detected 1 dependency cycles

You will have to make the rig not have circular dependencies like this for it to work.