Page MenuHome

can't remap Italian keyboard in keymap preferences
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 570 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.9.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-04 13:15, hash: rB5361fc2c3325
Worked: (never)

Short description of error
Using OSX and Italian keyboard some function are not available and is impossible to remap some keys since blender seems to reject their input in the keymap inputs.

Exact steps for others to reproduce the error
open blender on osx with Italian keyboard and try to activate the viewport pie menu. since the key "\" is Italian equivalent to tilde try to map that key in the keymap editor to replace the tilde. Blender will reject the input and ask again for a keystroke.

attached a sample of Italian keyboard. Other keys are not mappable. Search for brackets [ ] equivalent and so on.

Details

Type
Bug

Event Timeline

btw shouldn't be better to map basic keys like viewport pie menu to a key it's present in almost any language?

Afaik this is already solved on X11. Here we can map shortcuts to physical keys, meaning we can ensure that we map the pie menu to the button to the left of the number row

seems blender is not aware that button exists though. Attaching a video to show what happens.

Side note: if a developer at the Blender HQ wants to test further on macOS, I have several Italian layout keyboards.

There are two types of apple keyboards "US" and "International".

In the case of the "International", the tilde/accent-grave key is located to the left of Z key, and it works.
To the left of 1 is an additional key, and it seems that this physical key does not work regardless of the language.

It is also not possible to bind non ANSI keys such as á ö ù, as I understand it.

I recently noticed that in the Italian layout, by default the view pie menu is mapped to ò and local view is mapped to ù, in the keyboard settings if you try to use those keys they figure as ` and / , respectively. You also can't use modifier keys with them.

Sebastian Parborg (zeddb) triaged this task as Waiting for Developer to Reproduce priority.
Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

It is indeed similar issue as in T67130: keyboard layout problems., so… same answer. ;)

I think this should get an entry in the T63726: User Interface Module , but will let their owners (@Campbell Barton (campbellbarton)/@Brecht Van Lommel (brecht)/@William Reynish (billreynish)) decide about it.

In the mean while, since that’s not a bug, will archive the report, thanks.

@Bastien Montagne (mont29) Then you should at least consider moving this new 2.8 minimal keymap on keys that are available on most keyboard layouts, or maybe create new hacks. In effect the view pie menu is completely unavailable and not remappable in any way in italian layout. And you may imagine the user experience you get if you switch to an US layout keeping your keyboard italian.

@Ivan Cappiello (icappiello) I agree (and experienced similar issues on French keyboards since the beginning of my Blender usages ;) ). Just saying that this cannot be considered a bug, as it most likely requires a fair amount of work (including some design/research) to properly solve it… :/

@Bastien Montagne (mont29) do the code recognize the keyboard layout?
If so maybe a temporary "solution" could be to simply have a message in the keymap settings that warns about the special keys behaviour.