Page MenuHome

Spin tool
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: Intel(R) HD Graphics 630 Intel 4.5.0 - Build 26.20.100.6890

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-01 22:51, hash: rB079c7f918c81
Worked: (optional)

Short description of error
[the spin tool has no cancel and no confirm]

Exact steps for others to reproduce the error
[in blender if you right clic or cancel you can cancel an operation. and second thing if you left clic on empty zone like in other parts of blender (or enter) to confirm you are directly creating another one above the first one. and if you don't see it immediately, later you can't merge to clean because merge doesn't merge faces... ]
[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

William Reynish (billreynish) triaged this task as Needs Information from User priority.
  • Please describe the problem in a way that is possible to read and understand
  • Please provide exact steps to reproduce the issue
  • Preferably provide an example blend file that demonstrates the issue.
tom k (tomjk) added a subscriber: tom k (tomjk).EditedJun 6 2019, 10:50 PM

I think their problem is this:

  1. Select a face, go to spin tool, click-drag to start spinning.
  2. Now right-click to cancel.

Expectation: Be like I never invoked spin in the first place.
What Happens: All those faces created in the spin are now sat on the starting face. You performed a 0-degree spin.

This feels familiar to the thing where you "cancel" an extrude but the new geometry stays put. I'm quite happy with that behaviour. However I can't think of a good reason to ever perform a 0-degree spin, so I think cancelling should undo the spin.

Furthermore I believe they argue that you may try to clear it up later by merging by distance, but that this doesn't work. Now, in the case of accidentally spinning a face on the default cube by 0-degrees, I am able to get back to the default cube by merging by distance. So they'll have to elaborate on that one.

Demeter Dzadik (Mets) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

I think Tom's assessment of what this report is supposed to be is correct.

But I'm guessing it's not a bug? Either way, this no longer needs information from user, so let's wait for a developer to decide what to do with this. Being able to do a 0 degree spin does sound like at least a bit of a UX papercut. At the very least I think the default value for the Angle should be changed to 90, so that when a user executes the operator there is visual feedback.

Sebastian Parborg (zeddb) closed this task as Archived.
Sebastian Parborg (zeddb) claimed this task.

This is not really a bug, it is more of a paper cut. So I'll close this.