Page MenuHome

Latest Blender 2.8 Beta Crashes on Startup (MacOS)
Closed, ArchivedPublic

Description

System Information
Operating system: MacOS 10.9.5
Graphics card: NVIDIA GeForce GT 750M, NVIDIA GeForce GT 750M, PCIe, 2048 MB / Intel Iris Pro, Intel Iris Pro, Built-In

Blender Version
Broken: 3325b19ee7fd, and e80cbdac331a
Worked: a1ad71304c2d

Short description of error
Crashes on Blender.app startup with the following dialog: "blender cannot be opened because of a problem... [Ignore] [Report...]".

Exact steps for others to reproduce the error
After downloading and unzipping blender-2.80-3325b19ee7fd-OSX-10.9-x86_64.zip and copying blender app ("blender.app" folder) to the Applications folder, I right clicked on blender to start the application follow by clicking on the [Open] button.

It appears that somewhere between the end of May to the beginning of June that new changes now use a MacOS library called Metal.framework that is not available to older MacOS operating systems.

... Hum.. Looks like this is deliberate. :( On the a1ad71304c2d commit, the options.cmake says "set(OSX_DEPLOYMENT_TARGET 10.9)", the latest version say "set(OSX_DEPLOYMENT_TARGET 10.11)". That's too bad, I was hoping to learn Blender...

Report generated:

Process:         blender [6550]
Path:            /Applications/blender.app/Contents/MacOS/blender
Identifier:      org.blenderfoundation.blender
Version:         ???
Code Type:       X86-64 (Native)
Parent Process:  launchd [269]
Responsible:     blender [6550]
User ID:         501

Date/Time:       2019-06-06 17:02:08.548 -0400
OS Version:      Mac OS X 10.9.5 (13F1911)
Report Version:  11


Crashed Thread:  0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/Metal.framework/Versions/A/Metal
  Referenced from: /Applications/blender.app/Contents/MacOS/blender
  Reason: image not found

Binary Images:
    0x7fff6c1fe000 -     0x7fff6c231887  dyld (239.5) <1D3130FE-FE7E-3C4C-8E74-EB51895B6BA5> /usr/lib/dyld
    0x7fff8333d000 -     0x7fff83eb3ff7  com.apple.AppKit (6.9 - 1265.21) <9DC13B27-841D-3839-93B2-3EDE66157BDE> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
    0x7fff84f85000 -     0x7fff84ff1fff  com.apple.framework.IOKit (2.0.1 - 907.100.14) <10932113-9F7E-38A0-A158-A019A555CAC3> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x7fff855ca000 -     0x7fff855cafff  com.apple.Carbon (154 - 157) <EFC1A1C0-CB07-395A-B038-CFA2E71D3E69> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
    0x7fff88294000 -     0x7fff88294fff  com.apple.Cocoa (6.8 - 20) <E90E99D7-A425-3301-A025-D9E0CD11918E> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
    0x7fff88ea7000 -     0x7fff88ffbff3  com.apple.audio.toolbox.AudioToolbox (1.10 - 1.10) <69B273E8-5A8E-3FC7-B807-C16B657662FE> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
    0x7fff8cd5b000 -     0x7fff8cdacff7  com.apple.audio.CoreAudio (4.2.1 - 4.2.1) <07F2B103-AE29-3118-BBC4-9A72E13B013B> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
    0x7fff8e19b000 -     0x7fff8e49bff7  com.apple.Foundation (6.9 - 1056.17) <E0B0FAF6-5CA8-3EEB-8BF2-104C0AEEF925> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x7fff8e579000 -     0x7fff8e579ffd  com.apple.audio.units.AudioUnit (1.10 - 1.10) <68B21135-55A6-3563-A3D6-3E692A7DEB7F> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
    0x7fff8f6ea000 -     0x7fff8f6eafff  com.apple.CoreServices (59 - 59) <7A697B5E-F179-30DF-93F2-8B503CEEEFD5> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Archived.EditedJun 6 2019, 11:56 PM

The minimum OS version for Blender is macOS 10.11, which runs on Macs from 2007 and forward. Upgrade your OS and then Blender will work on your system.

Other similar 3d apps have similar system requirements.

Dear William,

Thank you for your suggestion... I will consider upgrading in the near future. Unfortunately, I can not afford to upgrade at this point in time. :( I guess I am old school, but I have too many legacy projects riding on a working machine that would likely cost months of additional work if I tried upgrading. Every time I upgraded, something else breaks. I do plan to invest in a new Windows / Linux based laptop since high-end MacBooks no longer offer real function keys so Blender should be much of an issue in the future...

In the mean time I did download your source code and after a few hours of fixing little compilation issues, finding old libraries, and working around the fact that the old XCode doesn't have thread_local to hold you GPUContext, I do have your latest Blender running now on MacOS 10.9.5. :) I guess I'll keep patching my own builds until I can migrate to a new workstation. Thank you again for replying, I really appreciate your time and suggestion.

Live Long and Prosper,

Alberto

Just FYI, the touch bar can show just F-keys.

As for your current system, if it is less than about 10 years old, you should be able to upgrade to 10.11 or higher. The competing DCC apps all seem to require 10.11 or 10.12 minimum too.

Dear William,

Thanks for the info and again for your suggestions. :) You're a good sales representative for Apple. :P Thanks to you, I discovered their new MacBook Pros 15" with 8-core i9's - Wow!. I have actually been eyeing a Lenovo ThinkPad P52 workstation with 6-core Xeon for a while. Although a year old now and not as fast, it can offer 4 times the RAM and twice the SSD (custom) storage capacity along with a 4K touch screen at less than two thirds the price of a fully loaded MacBook.

My MacBook Pros are old, 2013 and older. I didn't upgrade beyond 10.9.5 because last time I upgraded the OS, it broke some of my scripts and virtual machines and I lost a lot of time. I like touch screens but I am not sure that I can get accustom to the touch bar. I touch type and usually feel the location of the function keys while debugging without looking at them and I'm guessing that it might be a bit hard to do with a touch bar.

Sorry for using this issue management system as a form of chat... I discovered what appear to be a bug in the latest version of Blender 2.8 Beta. When I tried to follow one of the YouTube videos to draw a bezier curve then try to edit it, Blender 2.8 would crash. I have spent a few hours and discovered what appear to be a GPU related bug and corrected the issue in my own build but I don't know if the issue affect anyone else. I can't seem to find this issue being reported on developer.blender.org so I'm guessing it's because I'm using an older machine. If you know anyone else having this issue, please let me know and I'll try to figure out how to get my code fixes submitted...

Alberto