Page MenuHome

Glass transparency becomes opaque after I click in the viewport. (Eevee)
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7 pro
Graphics card: AMD Radeon RX 470 Version 18.3.4

Blender Version
Broken: version: 2.80 (sub 74), branch: blender2.7, commit date: 2019-06-04 00:52, hash: c13e10a7404d, type: Release
build date: 03/06/2019, 18:13

Short description of error

I was following along with this video from youtube (https://www.youtube.com/watch?v=posY9gHiQV0) which came with the file to use. I notice a few things that the video had working but mine did not.

First, after I made the same adjustments, glass had transparency, until I clicked in the viewport. I have watched and watched the video numerous times to see if I was missing anything but still nothing. I did reduce the transmission on the Principled shader and even the smallest reduction will make the glass object invisible.

Second: The reflections for the items on the table shows up on the video but mine did not.

Can anyone else get these items to work correctly?

Details

Type
Bug

Event Timeline

@Ray Alligood (ralligood) Have you tried to contact the creator of the video? It could be that the video you are following is out of date as a lot of changes have happened since then.

For feedback from other users use the appropriate forums like blender. https://blender.chat/channel/support or blender artists.

If you think that there is a bug in Blender, please describe the issue in a way how it is reproduceable for developers and report it here.

William Reynish (billreynish) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jun 7 2019, 3:41 PM

I did not contact the creator. The video is only 3 months old. I still think it's a bug.

Steps to recreate the problem.

Create 2 objects with one inside the other. (Like a plant in a glass jar)
The node setup on the glass object as follows:
Light Path -> Is Shadow Ray -----------Mix Shader-> Fac -----------Material Output->Surface
Transparent------------Mix Shader->Shader
Principled--------------Mix Shader->Shader
Principled Config:
IOR = 1.45
Transmission = 1
Alpha = 1

Added Reflection Cubemap and Irradiance Volume (If that matters at all)

Checked: Screen Space Reflections and refraction under Render
Checked: Screen Space Reflections and Subsurface Translucency under material with no additional settings changed.

It will appear to work until you click in the viewport.

Ray Alligood (ralligood) closed this task as Resolved.Jun 7 2019, 4:08 PM
Ray Alligood (ralligood) claimed this task.

Okay I think I figured it out. It would not work with the file I got from youtube because I was not using the same build that he used to create it. Once I created a new file and went through the steps it work. False alarm guys.