Page MenuHome

Volumetric Material Goes Black in Orthographic View
Closed, ResolvedPublic

Description

System Information
Operating system: Win 10
Graphics card: GeForce GTX 1060 3GB

Blender Version
Blender 2.8

If using volumetric materials whether it's attached to an object or used as a part of the World shader, if you go into Orthographic view in realtime render with EEVEE, the scene goes black. It doesn't matter what light is used or if you're using an emission material, it stays pitch black in Ortho view. See gif below.

Details

Type
Bug

Event Timeline

tom k (tomjk) added a subscriber: tom k (tomjk).EditedJun 8 2019, 1:40 PM

Can't reproduce in latest master with object volumetrics.
Does go darker with world volumetrics with ortho camera, which in a way is to be expected: an ortho camera is idealised as being infinitely far away, so an infinitude of even the thinnest atmosphere would obscure everything. The weird thing is that, for me, it doesn't go full black at low densities. Go to Properties->Render tab->Volumetric panel->increase End distance.

Some (not particularly rigorous) observations:

default cube with volumetric absorption, density=1.0:
perceptually identical in perspective and ortho

default cube with volumetric absorption, density=10.0:
ortho is actually lighter than perspective, because volume cards are less densely packed (decreasing the End distance in Volumetric panel (from default 100m to, say, 10m) will bring ortho result more in line with perspective)

default cube no volume, world with volumetric absorption, density=1.0:
as expected in perspective, black in ortho.

default cube no volume, world with volumetric absorption, density=0.1:
cube never quite disappears into darkness as you zoom out in perspective, and is always quite visible in ortho (again, you can increase Volumetric End distance to have more correct results in both perspective and ortho).

In conclusion:

I don't see any problems with objects with volumetrics.
The results for world volumes you see in ortho view are what you would expect.
You can improve results by changing values in the Volumetric panel.
Generally speaking, don't use world volumes of any sort if you plan to use an ortho camera.

Operating system: Linux-4.15.0-48-generic-x86_64-with-debian-stretch-sid 64 Bits,
Graphics card: GeForce GTX 750 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 384.130

Thanks for taking the time to reply. After updating today, the issue has resolved. It was happening even on a density of 0.1 on either the cube or the world. But it's no longer an issue. This was a problem for sometime that just was not changing for me until I updated again tonight.

Thanks for clearing up about the volumetrics on the world in Orthographic.

Sebastian Parborg (zeddb) closed this task as Resolved.Jun 14 2019, 3:23 PM
Sebastian Parborg (zeddb) claimed this task.