Page MenuHome

Visibility animation disabling Graph Editor / Dope sheet view and removing active selection
Closed, ArchivedPublic

Description

When keying the "Global Disable Viewport", 2 issues acure:

  1. The selected object gets unselected once it is keyed on OFF
  2. When the timeline in on a frame that the visibility is OFF - the animation keys and Graph editor don't display the keys anymore

This is especially annoying when you are editing the animation curves - you must go to a frame where the visibility is ON just to be able to edit.

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.39

Blender Version
Broken: version: 2.80 (sub 74), branch: blender2.7, commit date: 2019-06-09 21:43, hash: rB030c7df19da9
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

tom k (tomjk) added a subscriber: tom k (tomjk).EditedJun 10 2019, 12:31 PM

I believe this was addressed here https://devtalk.blender.org/t/blender-ui-paper-cuts/2596/2894. Does that work for you?

edit: above solves disappearing keys in timeline, but not deselection. Bit awkward as under normal circumstances you probably wouldn't want to have invisible objects still selected...

Thank for the reply,
Nope, that doesn't work.

Sebastian Parborg (zeddb) closed this task as Archived.
Sebastian Parborg (zeddb) claimed this task.

This not a bug. if you disable the object it will not be evaluated and thus not updated or refreshed. This is why it is not selectable or your are not able to view keyframes.

If nothing else, this is a feature request and should go to https://blender.community/c/rightclickselect/