Page MenuHome

Solidify Modifier produces rim surfaces with faces but no edges
Closed, InvalidPublic

Description

System Information
Windows 8.1

Blender Version
2.79b, Date 2018-03-22 14:10, Hash f4dc9f9d68b

Short description of error
Solidify modifier produces rim surfaces with faces but no rim surface edges. I'm concerned that may not work well with 3D printing.

I'm using these settings:

That's in contrast to the behavior seen in this demo video using version 2.68, which does include edges and with just the 'Only Rims' option if you look close, which is not the way the current version behaves at all.

https://www.youtube.com/watch?v=yIV59mmIF8c

Thanks for your time and for the wonderful Blender product!

Details

Type
Bug

Event Timeline

You Blender software developers and artists know far better what you're doing regarding Blender than I do. But I'd like to add this input. I'm trying to cut a typical (human) character in half so as to create a front and back half and then apply the Solidify modifier to each half to create two shells suitable for 3D printing. For that, it is important that the two corresponding rim surfaces mate exactly (same angles) or almost exactly. I'm noticing in experimenting with solidify that the two rim angles are not exactly complementary (testing with for example a UV sphere split at different distances from the poles). I'm trying to determine if their mate/join becomes more exact with increasing resolution. Though perhaps there are better ways to go about making mating shell sections from originally contiguous surfaces. Just my two cents worth. Thanks.

screenshots from that file:

the edges are there (indeed they must be, there can be no faces without edges) but not visible in edit mode. If you apply the modifier they will be there. Given the inside of the bowl has visible edges in edit mode, I think it makes sense that the rim should too.

For your question about 3d printing a human shell, I think a good way to go about that would be to solidify first, then bisect the mesh down the middle. That way you're guaranteed an exact mate.

I'm just curious why the edges don't show up. Notice that they don't show on the first of your three images, though their presence is evident. The edges show in object mode in wireframe and they don't show in edit mode at all.

I'd use bisect, but my characters have long irregular boundaries that don't correspond to a plane, and then I have the matter of how to resurface either side of the bisect, which leaves no surface in its wake. Does bisect have a non-planar cousin that I might explore?

Anyway, thank you so much!

I was given an excellent solution for exact join edges that goes like this:

Make a UV sphere then... In Edit Mode, select all faces to serve as the outer surface of the shell section (the C key enables quick Circle Selection). Back out to Object mode, Apply the Solidify Modifier. Back in Edit mode, Seperate by Selection the faces/vertices. Back to Object Mode, can pull out the outer and inner surfaces coupled together with G. Select->Select All by Trait->Non manifold to select the peripheral edges. Then Mesh->Edges->Bridge Edge Loops to turn them into faces.

Thanks again!

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is by design (so not a bug).

The edges are not shown in edit mode because we will only show edges that correspond to an original edge that you can select and modify.
If we draw the edges of the rim in edit mode, users might get the wrong idea that they could select them and move them.