Page MenuHome

File browser scrolls to new folder
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7
GPU: Radeon Vega 64, Divider version: 19.4.1
CPU: Intel Core i7-5960X

Blender Version
Broken: 2.80, blender-2.80.0-git.2404220e80a9-windows32
Works: 2.80, blender-2.80.0-git.2404220e80a9-windows64

Short description of error

When creating a new folder, the file browser scrolls slowly to the new folder.

Exact steps for others to reproduce the error

  • Save as
  • New folder

Details

Type
Bug

Event Timeline

I'm not sure this counts as a bug. It is more a quirk of your setup. If you didn't have hundreds of files named Aclaim* in the same folder, Blender could create its 'New Folder' and scroll to it reasonably quickly.

I can confirm this happens to me too.

Every time I have a folder containing 1144 "Aclaim" subfolders I also have to wait 12 seconds to add a new "Aclaim" folder! At this rate it is going to take forever to get to 10,000 Aclaims.

I thought sarcasm was prohibited on this strict bug tracker. But it's good to get some laughs. I miss my favourite dev triaging... :(

Just, full disclosure, this happened on a project folder that had ~50 items with most of the titles being NSFW.
Hence I created: N:\Temp\Blender\The Scroll to demonstrate the issue!

I thought sarcasm was prohibited on this strict bug tracker

It probably is - will get spanked later I'm sure. LOL

This issue does look interesting. Looks like it is probably creating an animation time based on some value times the number of entries, rather than dividing a target animation time by the number of entries. Only guessing for now. I'm pretty sure someone is actively playing with the File Browser with the idea of a major change to it for 2.81. So I might look into this myself once that is done. Or someone better and smarter will do so earlier. LOL

Will try to make that a bit quicker…

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Jun 17 2019, 5:32 PM
Bastien Montagne (mont29) closed this task as Resolved.Jun 18 2019, 9:58 PM

Should be fixed by rB3c1207e73094.

Just want to say thanks for fixing this. I know there was a bit of joking here about how relevant fixing something like this would be and who would have a folder with so many subfolders in it, so I just wanted to drop my 2cents that this actually did help me as I was actually in a situation like this. Where I work I create new Blender projects multiple times a day for creating product visualisations, and I've been working there for many years, each time I create a new sub folder in a massive folder full of all my scenes . My folder has now over 1300 sub-folders in it. I've been using Blender 2.8 for some scenes and noticed this quirk. Thankyou!