Page MenuHome

2.79: Relationship Lines Not Visible for Stick/B-Bone/Envelope & Wire Bone Types
Closed, ArchivedPublic

Description

System Information
OS: Manjaro 18.0.3 Illyria
Kernel: x86_64 Linux 4.19.24-1-MANJARO
DE: KDE 5.55.0 / Plasma 5.15.1
CPU: Intel Core i5-2400S @ 4x 3.3GHz [61.0°C]
GPU: AMD TURKS (DRM 2.50.0 / 4.19.24-1-MANJARO, LLVM 7.0.1)
RAM: 2114MiB / 3920MiB

Blender Version
Broken: f4dc9f9d68b
Worked: (optional)

Short description of error
Relationship Lines not visible for bone type other than Octahedral

Exact steps for others to reproduce the error
3D View --> N panel --> Display --> checkmark Relationship Lines
Add an armature and parent one bone to another
Relationship Lines should be visible in Pose mode & Edit mode but is invisible for Stick/B-Bone/Envelope & Wire

Details

Type
Bug

Event Timeline

I tried to replicate this using today's build (87de71a8aaa0) on a windows box but could not reproduce the described bug. I was able to see relationship lines for all armature display types in edit and pose mode. I do not have a linux box to test with.

I suggest you update to the latest version of blender 2.8 and re-test.
If the problem persists, try using factory settings with default scene to be sure you don't have a bug with an addon.

It's a version 2.79 build. 2.8 works fine, in factory settings the error is present. (2.79)

Not too sure if the devs are fixing non-crashing bugs in 2.79 any more.

However, firing up the default scene in 2.79 (same version as yours) and retesting showed exactly the same results for me in Windows 10/Nvidia GPU. All relationship lines show up in all armature display types. Maybe it's a bug specific to the Linux version or the AMD card.

Philipp Oeser (lichtwerk) renamed this task from Relationship Lines Not Visible for Stick/B-Bone/Envelope & Wire Bone Types to 2.79: Relationship Lines Not Visible for Stick/B-Bone/Envelope & Wire Bone Types.Jun 17 2019, 12:00 PM
Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

Also cannot reproduce here in 2.79 (as well as 2.8).
And since this is confirmed to work in 2.8, I assume this can be closed [there are many things fixed in 2.8 which dont get a backport back to 2.79...]