Page MenuHome

ALT+D duplication removes particles from original object
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-18.5.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) Iris(TM) Graphics 6100 Intel Inc. 4.1 INTEL-12.8.38

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-16 11:16, hash: rB3e086af79ceb
Worked: (optional)

Short description of error
When an object with a particle system is duplicated with ALT+D the particle system is removed from the original object that is being copied.

Exact steps for others to reproduce the error

  1. Select an object with a particle system.
  2. Press the ALT+D shortcut keys.
  3. Move and place the copy with left click.
  4. Now the particles does not show any more on the original object.

The included blend file can be used to demonstrate the problem:

Details

Type
Bug

Event Timeline

I see now that the original object's particle system is not removed as I claimed but for some reason the particles are not showing on the original object.

I also found that when I toggle "Display modifier in viewport" (modifiers["Subdivision"].show_viewport) for the particle system modifier on the original object the duplicate does not display the particles either.

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Confirmed.

Renders fine though with F12, so seems to be a viewport drawing issue...
@Clément Foucault (fclem): does this ring a bell?

I can't reproduce this bug in the last 2.8 master. Can you confirm @Roelf De Kock (kiemdoder) ? If this is fixed for you, you can close the bug report with add action > change status > resolved

I can confirm that the bug I reported is fixed in blender-2.80.0-git20190623.6182531baf4b-x86_64.