Page MenuHome

Lamp data color not replaced when using nodes in cycles
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.91

Blender Version
Broken: version: 2.80 (sub 74), branch: blender2.7, commit date: 2019-06-15 22:35, hash: rB87de71a8aaa0
Worked: (optional)

Short description of error
In Cycles, the data color of the lamp is not replaced but multiplied when using the nodes shading.

Exact steps for others to reproduce the error
Open the default scene
Select the point lamp
Change the data color to red
In the object data, click on "Use Nodes"
In the Emission node, change the color to blue.
The lamp color should be blue, but instead of replacing the data color, the color is multiplied.


Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This is by design, the shading nodes are intended to be an additional effect and not to replace the color.

Ok, thanks, i thought it was a bug..

Sorry to bother you, but just for my information, why not just set the color data to full white and hide it if "Use nodes" is checked ?

Maybe that is because EEVEE does not support nodes for the moment, but what is the benefits of this design as a user ? because it is very confusing. If I check "Use Nodes", I'm expecting to use only the nodes. Is it the same for the strength and the power ?

Thanks again for your help.

It's the same for strength and power, and it's useful to be able to share lights with Eevee and to allow units to be used for power.