Page MenuHome

Blender crashes when closing certain windows in tiling WMs
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.1.9-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700K_CPU_@_4.20GHz-with-gentoo-2.6 64 Bits
Graphics card: Radeon RX Vega (VEGA10, DRM 3.30.0, 5.1.9-gentoo, LLVM 8.0.0) X.Org 4.5 (Core Profile) Mesa 19.1.0

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-18 12:01, hash: rB0b73817c8cf4

Short description of error
With certain multi window setup, blender crashes when closing one of the windows.
It seems only to happen with the Mesa drivers though as @Jeroen Bakker (jbakker) wasn't able to reproduce this on his AMD card with the proprietary drivers

Exact steps for others to reproduce the error

  1. Open this file:
  2. Close the window with the bark texture in it.
  3. Blender crashes

Backtrace:

Thread 1 "blender" received signal SIGSEGV, Segmentation fault.
0x00007fffe2bc7178 in ?? () from /usr/lib64/dri/radeonsi_dri.so
(gdb) bt
#0  0x00007fffe2bc7178 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#1  0x00007fffe2ae28dd in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fffe2ae2ea5 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fffe2ad07b2 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#4  0x00007fffe2aa0c10 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#5  0x00007fffe2a809da in ?? () from /usr/lib64/dri/radeonsi_dri.so
#6  0x00007fffe2a80a1e in ?? () from /usr/lib64/dri/radeonsi_dri.so
#7  0x00007fffe2a80ac9 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#8  0x00007fffe2a7c25c in ?? () from /usr/lib64/dri/radeonsi_dri.so
#9  0x000055555cacd6e3 in orphans_clear (ctx=0x7fffdbe92800) at /home/zed/prog/blender/source/blender/gpu/intern/gpu_context.cpp:121
#10 0x000055555cacdb2d in GPU_context_active_set (ctx=0x7fffdbe92800) at /home/zed/prog/blender/source/blender/gpu/intern/gpu_context.cpp:188
#11 0x00005555586a70ad in DRW_opengl_context_enable_ex (restore=true) at /home/zed/prog/blender/source/blender/draw/intern/draw_manager.c:3203
#12 0x00005555586a7192 in DRW_opengl_context_enable () at /home/zed/prog/blender/source/blender/draw/intern/draw_manager.c:3239
#13 0x000055555caf0eb7 in GPU_viewport_bind (viewport=0x7fffd2abdf48, rect=0x7fffe541ef00)
    at /home/zed/prog/blender/source/blender/gpu/intern/gpu_viewport.c:470
#14 0x0000555558221869 in wm_draw_region_bind (ar=0x7fffe541ee48, view=0) at /home/zed/prog/blender/source/blender/windowmanager/intern/wm_draw.c:377
#15 0x00005555582222a5 in wm_draw_window_offscreen (C=0x7fffeb891208, win=0x7fffe6764788, stereo=false)
    at /home/zed/prog/blender/source/blender/windowmanager/intern/wm_draw.c:595
#16 0x0000555558222836 in wm_draw_window (C=0x7fffeb891208, win=0x7fffe6764788) at /home/zed/prog/blender/source/blender/windowmanager/intern/wm_draw.c:732
#17 0x0000555558222d42 in wm_draw_update (C=0x7fffeb891208) at /home/zed/prog/blender/source/blender/windowmanager/intern/wm_draw.c:895
#18 0x000055555821ecd0 in WM_main (C=0x7fffeb891208) at /home/zed/prog/blender/source/blender/windowmanager/intern/wm.c:423
#19 0x0000555557b79819 in main (argc=1, argv=0x7fffffffdff8) at /home/zed/prog/blender/source/creator/creator.c:500

@Clément Foucault (fclem), Jeronen took a quick look at this and it might be a race condition or something on our end. What is your take on this?

EDIT:
This actually seems to be related to tiling window managers. It seems to crash only if the main window is resized to fill the desktop as the other is closed.
EDIT2:
This seems to be a bug in newer Mesa versions.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Waiting for Developer to Reproduce priority.
Sebastian Parborg (zeddb) renamed this task from Blender crashes when closing certain windows to Blender crashes when closing certain windows in tiling WMs.Tue, Jun 18, 2:57 PM
Sebastian Parborg (zeddb) closed this task as Archived.EditedTue, Jun 18, 5:46 PM

I've bisected the mesa commit that broke this and filed a bug report here: https://bugs.freedesktop.org/show_bug.cgi?id=110944