Page MenuHome

Keymap (preferences) Add Vertex for mesh? I see only this option for curves
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 64), branch: master, commit date: 2019-05-13 19:09, hash: rB27d097e92d54
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

Mesh vertex creation mechanisms are in abundance; just not labeled as such. They come part-and-parcel with duplication (Shift-D), extrusion(E) and subdivision. Some single vertex creation steps I commonly use:

  1. In mesh edit mode - select any existing vertex reasonably close to where the new vertex should be.

2a. Shift-D creates a new - wholly disconnected - vertex. Implicitly, G (grab) has been invoked. Move the wholly disconnected vertex to someplace useful.
2b. E extrudes a new vertex from the selected existing vertex; the two vertices are connected by an edge. Again, G has been implicitly invoked to move the new vertex to someplace useful.
2c. With a pair of selected vertices connected by an edge, right-mouse button menu brings up the subdivision menu. Subdivide once to get a new vertex between the two selected vertices, midway on the connecting edge.

With these existing methods, I surmise that a need for an explicit "Add vertex here" was never felt, but 2a is close to that in practice. Hope this helps.

The Add Vertex called Duplicate or Extrude to Cursor in the case of mesh.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

The naming inconsistency is not ideal, but not a bug.