Page MenuHome

AMD Radeon Settings Hijacks Blender's Shortcuts
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: AMD R9 390

Blender Version
Broken: 2.80, 87de71a8aaa0, master, 2019-06-15

Short description of error

Exact steps for others to reproduce the error
When AMD's driver software (AMD Radeon Settings) is launched it takes away several shortcuts from Blender.
CTRL+R and many more. I believe this is because it's assigned as AMD Relive's shortcuts. Once this bug is triggered
resetting keys, re-initializing and even deleting the Blender Foundation folder won't fix it. You loose your shortcuts forever
and I only got them back by reinstalling the AMD software and they worked until I launched the AMD Radeon Settings again.

Blender is unusable for me without the shortcuts and this may be affecting a lot of AMD users. I hope you can contact them and get
this fixed.

Thanks

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

You can report issues to AMD directly:
https://www.amd.com/report

We can mention it to the AMD developers, but since there are many reports about this online for other applications I'm sure they are aware.

Juan Rios (Zeriel) added a comment.EditedWed, Jun 19, 2:43 PM

Thanks, I submitted the report to AMD
Is there anything else I can do? I literally can't use Blender without Shortcuts because everything takes so long :(
I'm trying to move from Maya.

Thanks for looking into this.