Page MenuHome

Mesh displaced in render with multiple modifiers, fine in viewport
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Intel Graphics

Blender Version
Broken: 2.80.74, 741641f4c3b8, beta, 2019-06-17 21:07

Worked: (optional)

Description:

When using multiple modifiers, the cloth gets displaced/vertices explode when rendering. Looks fine in the veiwport. I have baked, cleared bake. Used to work fine with previous versions. Maybe its a modifier stack issue? or changes made to the cloth. It also sometimes gives me
" Number of points in cache does not match mesh " error in cloth modifier

Steps:

Add cube > Subdivide(3 levels) > Add soft body modifier> Quick Explode(remove material) > Add cloth modifier

Go to Particle settings: Set lifetime to 500 > Enable 'Use Modifier Stack'> Change particle physics type to 'Keyed'

Go to Soft Body settings: Under Goal options, change Strength default to 0

Run animation & stop on frame 20(or any) & render image.

Looks perfect in Viewport & not in Render.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

Please attach a .blend file to reproduce the issue, there's too many steps here to reliably reproduce.

Brecht Van Lommel (brecht) closed this task as Archived.Jul 2 2019, 7:59 PM
Brecht Van Lommel (brecht) claimed this task.

Closing due to lack of information to reproduce the issue, we can reopen the report if more information is provided.