Page MenuHome

Cycles/Ctest : OSL Failing tests.
Closed, ResolvedPublic

Description

System Information
Operating system: Win64 (but pretty sure all other platforms will fail as well)
Graphics card: N/A

Blender Version
Broken: 2f77175fecc7
Worked:

Short description of error

When running a debug build through the test suite the following assertion crashes blender for many of the test files

62: Assertion failed: colorspace != u_colorspace_srgb && colorspace != u_colorspace_auto, file K:\BlenderGit\blender\intern\cycles\render\colorspace.cpp, line 51

Exact steps for others to reproduce the error

render any of the following files

62: [ FAILED ] image_alpha_blend_osl
62: [ FAILED ] image_alpha_channel_packed_osl
62: [ FAILED ] image_alpha_ignore_osl
62: [ FAILED ] image_non_color_osl
64: [ FAILED ] image_mapping_clip_closest_1px_osl
64: [ FAILED ] image_mapping_clip_closest_osl
64: [ FAILED ] image_mapping_clip_cubic_1px_osl
64: [ FAILED ] image_mapping_clip_cubic_osl
64: [ FAILED ] image_mapping_clip_linear_1px_osl
64: [ FAILED ] image_mapping_clip_linear_osl
64: [ FAILED ] image_mapping_extend_closest_1px_osl
64: [ FAILED ] image_mapping_extend_closest_osl
64: [ FAILED ] image_mapping_extend_cubic_1px_osl
64: [ FAILED ] image_mapping_extend_cubic_osl
64: [ FAILED ] image_mapping_extend_linear_1px_osl
64: [ FAILED ] image_mapping_extend_linear_osl
64: [ FAILED ] image_mapping_repeat_closest_1px_osl
64: [ FAILED ] image_mapping_repeat_closest_osl
64: [ FAILED ] image_mapping_repeat_cubic_1px_osl
64: [ FAILED ] image_mapping_repeat_cubic_osl
64: [ FAILED ] image_mapping_repeat_linear_1px_osl
64: [ FAILED ] image_mapping_repeat_linear_osl

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) edited projects, added Cycles; removed BF Blender.

I am not able to reproduce. I build a test build with abort on assert turned on. It could be that I started the test differently...

ctest -R cycles_image_mapping
Test project /home/jeroen/blender-git/build_linux
    Start 27: cycles_image_mapping
1/1 Test #27: cycles_image_mapping .............   Passed   60.44 sec

100% tests passed, 0 tests failed out of 1

Total Test time (real) =  60.44 sec
Brecht Van Lommel (brecht) closed this task as Resolved.
Brecht Van Lommel (brecht) claimed this task.

I already solved this a while ago.