Page MenuHome

Blender doesn't quit.
Closed, ArchivedPublic

Description

System Information
Operating system: Win64
Graphics card: N/A

Blender Version
Broken: 2f77175fecc7
Worked: (optional)

Short description of error
Blender does not quit when there is unsaved data.

Exact steps for others to reproduce the error
With the default cube scene.

  1. Delete the cube
  2. Quit blender, by either using the menu item or the X in the upper right corner of the window
  3. This file has not been saved yet! save? Sure. why not.
  4. Enter filename, save
  5. Blender returns to the 3d view
  6. click X again.
  7. ahhh now we quit...

mentioned this informally to @Harley Acheson (harley) on chat but unsure if he's working on a fix or not.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Jun 20 2019, 7:14 PM

This is a known issue - mainly due to limitations in the operator system.

@Jacques Lucke (JacquesLucke) has fought with this.

It's still a valid issue, so I set it to Confirmed, but there seems to be no immediate solution.

I did make a patch for that, and subsequently abandoned it. The patch addressed the above steps perfectly. It quit after saving a new file, and it did not quit if you selected "cancel" in the File Manager.

The problem is that it broke related behavior. So opening a blend file, or creating a new one, while you have a never-saved file open. In that case it would prompt to save and then quit when you want to carry on with the new file. Looking through all this stuff (wm_files.c) I can't see any easy way to get that early intention (quit or carry on) to where it needs to be acted on after the file manager save. It is a complicated dance and will leave it for someone else smarter. LOL

Brecht Van Lommel (brecht) closed this task as Archived.Jul 3 2019, 4:47 PM
Brecht Van Lommel (brecht) claimed this task.

We should improve this, but it's not a bug.

what is our definition of a 'bug' ? I always used 'works as designed, but perhaps not optimal' as the cut off for closing tickets as 'not a bug'

But you surely can't be making the case here that we designed File->Quit not to quit, File->New not to give me a new file and File->Open not to open a file if there was work to be saved?

Don't get me wrong, I appreciate that the deeper underlying issues are not easy to solve, but hard to solve bugs, are bugs.

it's strange UI like this that make people go 'blender is just weird for the sake of being weird'

There was a code review for the quit dialog changes, where this was accepted as a known limitation.