Page MenuHome

Cycles - Volume rendering fails when Film Transparent is on
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX TITAN X/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-19 18:29, hash: rBd30f72dfd8ac
Worked: 2.79

Short description of error
Cycles - Volume rendering fails when Film Transparent is on

Exact steps for others to reproduce the error


Open the attached blend-file.
Click render Image. Nothing is rendered.
Switch Transparent off in the render settings.
Render Image again. The volumes are shown but with grey background.
So no compositing of volumes is possible because they can´t be rendered without the background.

That worked in blender 2.79.**
See Attached 2.79 blend-file. Repeat the same steps as above in Blender 2.79b.

Event Timeline

Brecht Van Lommel (brecht) changed the task status from Unknown Status to Unknown Status.Jun 21 2019, 11:38 AM
Brecht Van Lommel (brecht) claimed this task.

Connecting a volume scatter output to a color attribute is not a valid setup.

The rest of the issue here is the same as T52680: Alpha difference Viewport/F12 .

Marcus Papathoma (machieb) changed the task status from Unknown Status to Unknown Status.Jun 21 2019, 11:39 AM
Marcus Papathoma (machieb) removed Brecht Van Lommel (brecht) as the assignee of this task.
Marcus Papathoma (machieb) updated the task description. (Show Details)
Brecht Van Lommel (brecht) changed the task status from Unknown Status to Unknown Status.Jun 21 2019, 11:39 AM
Brecht Van Lommel (brecht) claimed this task.