Page MenuHome

Graph editor curve display ignores scene's Unit System for X/Y/Z position and gravity value
Closed, ArchivedPublic

Description

Operating system: Kubuntu 18.10, 4.18.0-22-generic #23-Ubuntu SMP Tue Jun 4 20:22:46 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Graphics card: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)
Broken: 2.80, 9c5d54bfaf48, 2019-06-08 13:24

If I change the Scene's Unit Sytem for rotation between degrees and radians, the graph editor curves update accordingly in relation to the graph editor Y axis. Manipulation of points in the graph editor also works as expected (e.g. selecting a point and doing "G Y 1 enter" adds one radian or degree, as appropriate.)

If I change the Scene's Unit System for distance from metric to imperial, the curves do not update -- they are always in meters in the Y axis of the graph editor, and manipulation of points in the graph editor is always done in meters ("G Y 1 enter" always adds 1 meter, not 1 foot, as expected.)

Same issue is present for e.g. animating the "Gravity" parameter of the scene, which is in m/s^2 and always displayed in reference to meters in the graph editor, regardless of selected Unit System. I suppose there may be other examples as well.

Details

Type
Bug

Event Timeline

Not really a bug but a limitation of the units system.

@Jacques Lucke (JacquesLucke) thoughts? Can the graph editor be made to use the units?

Thanks -- one of the main issues to my mind is that the units in the N menu of the graph editor itself use one unit system, and the points use another:

Fingers crossed that it's not too difficult to fix/implement, given that it already happens with degrees/radians.

@William Reynish (billreynish) yes, it should be possible to use units in the graph editor. However, there are also issues. E.g. what happens when different fcurves use different units?

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Might be good to improve once, but not a bug.

@Jacques Lucke (JacquesLucke) Isn't it already supported for radians vs degrees? In that case the fcurves are using different units, but the graph editor Y axis is just showing a unitless value, right? Or do I misunderstand?